Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Cars in General
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 11-04-2016, 12:41 AM   #1
sellanycar
AF Newbie
 
Join Date: Sep 2016
Location: Dubai
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Battery Maintainer Not Charging Connected to Cobalt Remote Terminals

My Schumacher Battery Maintainer has worked fine for several years in keeping the battery charged in my 2014 Honda Civic. The first time I've used it on my 2010 Chevy Cobalt (attached to the remote terminals under the hood), the pulsating green light that indicates "fully charged" has not come on after 12 hours.

Is there something wrong about charging via the remote terminals?
sellanycar is offline   Reply With Quote
Old 11-24-2016, 12:47 PM   #2
dragonsgate
AF Newbie
 
Join Date: Nov 2016
Location: eureka, Arkansas
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
Re: Battery Maintainer Not Charging Connected to Cobalt Remote Terminals

Check the battery for a bad cell. The resistance in a bad cell will make the charger keep going.
dragonsgate is offline   Reply With Quote
Old 11-24-2016, 11:30 PM   #3
jasongraygits
AF Newbie
 
Join Date: Sep 2016
Location: Dubai
Posts: 58
Thanks: 2
Thanked 2 Times in 2 Posts
Re: Battery Maintainer Not Charging Connected to Cobalt Remote Terminals

If you have one of those small inexpensive battery maintainers, they aren't meant to charge up a fully discharged battery. They work best on a battery that is already fairly well charged up and just needs a little topping up.
jasongraygits is offline   Reply With Quote
Old 11-24-2016, 11:37 PM   #4
Stealthee
Your worst nightmare
 
Stealthee's Avatar
 
Join Date: Oct 2004
Location: Smithfield, Pennsylvania
Posts: 5,468
Thanks: 5
Thanked 143 Times in 140 Posts
Re: Battery Maintainer Not Charging Connected to Cobalt Remote Terminals

I've had difficulties getting a good connection on the remote terminals. I was trying to jump start a Cobalt once and was unsuccessful in getting it to start with the remote terminals even after making several adjustments to the connections.

I was finally able to get into the trunk and hooked directly to the battery and the car fired right up.
__________________
Stealthee is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks

Tags
battery, charging, maintenance, repair
Go Back   Automotive Forums .com Car Chat > Cars in General

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:26 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts