Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Isuzu > Rodeo | Passport | MU
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 01-17-2009, 08:07 PM   #31
skippertoo
AF Newbie
 
Join Date: Jan 2008
Location: Atlanta, Georgia
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Re: can somebody tell me why my horn keeps going off on my 99 isuzu rodeo

Quote:
Originally Posted by 1958Jon
Yes, the horn sticking problem started for me this past December on my 1999 Rodeo. It was easy to locate and pull the 10 amp fuse and I just figured I would re-plug it for state inspection. I started noticing the headlights diming and brightening while idling. I started thinking the voltage regulator must be going out. One morning it was especially bad with the engine lurching along with the lights. I had a hunch and plugged that horn fuse in, engine smoothed out and head lights stayed steady! In typical automotive design brilliance that fuse is used for more than the label indicates. Looking at the schematic in the Haynes book I have, it appears that the crank or cam position senser is also in that fuse circuit (not real clear). Pulling the fuse is only good for quieting the horn in the middle of those cold nights.

Can anyone tell me if the single green wire coming out of the steering column is the horn wire? If not which one? My diagram does not even show the horn circuit. I want to use the $2 solution.



Jan 2009 .... Cold outside and it started again so I pulled the fuse AGAIN

Sure would like someone to answer the last two requests about the correct wire

thanks
skippertoo is offline   Reply With Quote
Old 05-27-2016, 08:47 AM   #32
Juney
AF Newbie
 
Join Date: May 2016
Location: Bournemouth
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: can somebody tell me why my horn keeps going off on my 99 isuzu rodeo

I battled with the same problem for over a week. Car lights would now and then start flashing and the horn would sound simultaneously. Also, the car locks were opening and closing on their own at the same time as the horn and lights. I tried everything suggested here and more besides. Cutting a week-long story short, the problem turned out to be a failing key fob battery. I unscrewed the fob, removed the round battery and waited... problem solved! *Couldn't believe that such a major problem had such a simple solution. It's worth noting that when I ordered the new battery, I ordered an extra for the spare key fob. It may not work for everyone but it's worth a try. Hope that helps someone.*
Juney is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Isuzu > Rodeo | Passport | MU

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:43 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts