Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > GMC > Yukon
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 03-11-2019, 03:44 PM   #1
Throbbin Rods
AF Newbie
 
Join Date: Nov 2009
Location: Lebanon, New Hampshire
Posts: 44
Thanks: 2
Thanked 0 Times in 0 Posts
2004 Yukon Denali Power Heated seat issues

2004 Yukon Denali, heated seats and power seats went out this morning on the way to work. Got home, checked the MBEC1 fuse and it was blown. Replaced the fuse and the power seat now works. Heated seats still not working. I checked IGN3 and it appeared fine but I replaced it anyway. Still no heated seat. I tried both sets of controls in case the driver side switch had crapped out but no difference. I would be very grateful for any ideas.
Thanks,
Bill
Throbbin Rods is offline   Reply With Quote
Old 03-20-2019, 11:44 AM   #2
Throbbin Rods
AF Newbie
Thread starter
 
Join Date: Nov 2009
Location: Lebanon, New Hampshire
Posts: 44
Thanks: 2
Thanked 0 Times in 0 Posts
Solved

Issues was solved by replacing Blower Control Module
Throbbin Rods is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > GMC > Yukon

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:17 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts