Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Chevrolet > Malibu
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 01-11-2019, 06:10 PM   #1
spenser46
AF Newbie
 
Join Date: Mar 2015
Location: mckeesport, Pennsylvania
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Fuel Injector Balance Test

I have a 2010 2.4L ecotec p0172 code. When I did the injector balance test using my Tech 2 scanner. The pressure dropped from 52psi to 12 psi for each injector. That seems awful high pressure drop. I know the specs for a 2.2L ecotec for a good injector is between 9 to 11 psi. You can also email the answer spenser46 @ c o m c a s t . n e t. Just take the spaces out. Thanks

Last edited by spenser46; 01-12-2019 at 09:17 AM.
spenser46 is offline   Reply With Quote
Old 01-11-2019, 09:41 PM   #2
maxwedge
A990 racer
 
Join Date: Mar 2002
Location: Chestertown, New York
Posts: 16,533
Thanks: 13
Thanked 320 Times in 314 Posts
Re: Fuel Injector Balance Test

Ok, the pcm sees a lean mixture, the maf can cause this as well as a vacuum leak, have you eliminated this possibility?
__________________
maxwedge is offline   Reply With Quote
Old 01-12-2019, 09:17 AM   #3
spenser46
AF Newbie
Thread starter
 
Join Date: Mar 2015
Location: mckeesport, Pennsylvania
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Fuel Injector Balance Test

I meant to type p0172 rich. That's why I did the balance test. Yes both up and down stream o2 sensors are responding properly. Also Fuel Alcohol content is about 10% which is about where it should be.
spenser46 is offline   Reply With Quote
Old 01-12-2019, 10:34 AM   #4
maxwedge
A990 racer
 
Join Date: Mar 2002
Location: Chestertown, New York
Posts: 16,533
Thanks: 13
Thanked 320 Times in 314 Posts
Re: Fuel Injector Balance Test

Again a bad maf can cause this, by misreporting the airflow. Remember the maf and map sensors both adjust mixture based on percieved altitude.
__________________
maxwedge is offline   Reply With Quote
Old 01-12-2019, 11:14 AM   #5
Blue Bowtie
Registered Offender
 
Blue Bowtie's Avatar
 
Join Date: Mar 2006
Location: Rural
Posts: 5,930
Thanks: 3
Thanked 237 Times in 233 Posts
Re: Fuel Injector Balance Test

I might have missed something in that first post, but I don't see a question there, just a statement of what is approximately normal operation.

Max listed a couple possibilities related to the 0172, and those are fairly easy to check.

Another possibility is that although the sensors are responding correctly, the typical failure mode for a zirconia type oxygen sensor is to report a decreasing EGO so that the PCM keeps leaning out the mix until it exceeds the fault tolerance. Do you have a gas analyzer to actually check the EGO and confirm the sensors are not weak?
__________________
Permanent seat assignment on the Group W bench...
Automotive Forums Survival Guide
Blue Bowtie is offline   Reply With Quote
Old 01-12-2019, 01:01 PM   #6
spenser46
AF Newbie
Thread starter
 
Join Date: Mar 2015
Location: mckeesport, Pennsylvania
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Fuel Injector Balance Test

I know this and the Maf Map Baro Tps are all good. I just need what the proper fuel pressure drop is when injector is pulsed. picoscope shows good wave form on injector pulse. What I am saying is a 40 psi pressure drop is a lot. I can't find any documentation on what the drop should be.
spenser46 is offline   Reply With Quote
Old 01-12-2019, 01:43 PM   #7
maxwedge
A990 racer
 
Join Date: Mar 2002
Location: Chestertown, New York
Posts: 16,533
Thanks: 13
Thanked 320 Times in 314 Posts
Re: Fuel Injector Balance Test

I think you will have problems finding a spec range because of all the variables. Check the baro readings the pcm is recieving, make sure it matches your area. Any fuel in the pressure regulator hose if equipped like that?
__________________
maxwedge is offline   Reply With Quote
Old 01-13-2019, 07:35 AM   #8
Blue Bowtie
Registered Offender
 
Blue Bowtie's Avatar
 
Join Date: Mar 2006
Location: Rural
Posts: 5,930
Thanks: 3
Thanked 237 Times in 233 Posts
Re: Fuel Injector Balance Test

Max is right. Rail and regulator volume, temperature, a few ÁS difference in pulse width, and other variables will affect the drop. I've never considered that a very reliable indication, and the validity of the test (in my book) is to indicate whether all the injectors are flowing about the same, and not whether they meet any kind of flow standard. The only reliable method for testing that is to pull all the injectors and flow test them in a bench fixture measuring liquid volume over pulse time.

If all your injectors are providing the same drop, they are probably relatively close in flow across the set - or at least close enough for your PCM to work with them. That still doesn't tell us it the injectors are atomizing or streaming, what the hot performance might be, whether they are flowing at a design volume, or anything else.
__________________
Permanent seat assignment on the Group W bench...
Automotive Forums Survival Guide
Blue Bowtie is offline   Reply With Quote
Old 01-19-2019, 10:56 AM   #9
Tech II
AF Fanatic
 
Join Date: Jul 2011
Location: Worcester, Massachusetts
Posts: 4,985
Thanks: 62
Thanked 614 Times in 606 Posts
Re: Fuel Injector Balance Test

I seriously doubt all injectors would go bad at the same time.....if you get the same reading for all, I would guess they are ok.....

As mentioned, I would clean the MAF sensor with MAF cleaner......

Is your air filter OK?

Have you checked for vac leaks?

I assume your long term fuel trims are out of spec?

After cleaning the MAF, reset your fuel trims with the Tech II, and clear code ......run vehicle, and then take a snapshot of fuel trim and Pre O2 data......does O2 go lean, causing fuel trim to go rich?

If it does, disconnect the MAF, rest trims, clear codes if any.... and take another snapshot.....a MAF code will set, but does the O2 data still go lean?
Tech II is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Chevrolet > Malibu

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:40 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts