Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Eagle > General Discussion
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 07-04-2018, 10:36 PM   #1
anhnguyen1200
AF Newbie
 
Join Date: Jul 2018
Location: hcm
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
need help?

My 98-eagle talon has a clutch engagement problem. This happened without warning. The clutch is not engaging at all. I did get it home by forcing it into gear and it did not slip after it was in gear. It looks as though the slave cylinder is pushing, but I donít know if it is pushing far enough. The master cylinder has plenty of fluid and hasnít been leaking. The fluid is dark. Could this be clutch or master cylinders?
anhnguyen1200 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Eagle > General Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:57 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts