Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Geo > Metro
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 05-23-2014, 01:15 PM   #16
Crvett69
AF Moderator
 
Crvett69's Avatar
 
Join Date: Oct 2004
Location: Bellingham, Washington
Posts: 1,749
Thanks: 0
Thanked 73 Times in 73 Posts
Re: '93 Geo Metro Problem - Intermitant and Enigmatic

the grease is probably oil that seaped past the internal seal and cooked there
Crvett69 is offline   Reply With Quote
Old 05-24-2014, 07:30 PM   #17
DOCTORBILL
Geo Metro Lover
Thread starter
 
DOCTORBILL's Avatar
 
Join Date: May 2005
Location: Eastern Washington State, Washington
Posts: 1,617
Thanks: 0
Thanked 0 Times in 0 Posts
Re: '93 Geo Metro Problem - Intermitant and Enigmatic

It was the Distributor !

I drove the Metro into town today, went shopping and Garage sale'ing and not one single cough or miss.

Must have put 90 miles on it, starting / stopping, killing the engine innumerable times, starting it up, up hills - down hills -
all the conditions where I saw intermittent missing before and it drives as it used to before last winter.

The Distributor is the LAST THING I would have thought causing the intermittent missing.
Especially with it not having any obvious defects in the rotor vanes or the coil's appearance.
I must assume it is the electrical coil within it that is 'bad'.

Murphy's Law.

So - I hate to toss the old Distributor in the Trash.
Don't know who would want it, though.

Wonder if NAPA would send it back to whoever rebuilds these things for Metro's ?

Shame to toss it.....it is a nicely machined piece of equipment and becoming rarer each year.

Unless the Metro starts acting up again in a while - this should be the end of my tale.

DoctorBill
__________________

DOCTORBILL is offline   Reply With Quote
Old 05-24-2014, 07:36 PM   #18
Crvett69
AF Moderator
 
Crvett69's Avatar
 
Join Date: Oct 2004
Location: Bellingham, Washington
Posts: 1,749
Thanks: 0
Thanked 73 Times in 73 Posts
Re: '93 Geo Metro Problem - Intermitant and Enigmatic

your welcome
Crvett69 is offline   Reply With Quote
Old 05-24-2014, 08:37 PM   #19
DOCTORBILL
Geo Metro Lover
Thread starter
 
DOCTORBILL's Avatar
 
Join Date: May 2005
Location: Eastern Washington State, Washington
Posts: 1,617
Thanks: 0
Thanked 0 Times in 0 Posts
Re: '93 Geo Metro Problem - Intermitant and Enigmatic

Oh !

Sorry Crvett69 - you did say you suspected the Distributor back when I first posted this Thread......!

Thank you for the advice.

I actually missed that !

Thought I had fingered it out myself by a process of elimination.

Guess I was full of "elimination" as it were.

Thanks for your help on this issue.

I was actually considering getting rid of the Phoenix !
Imagine that !

DoctorBill
__________________


Last edited by DOCTORBILL; 05-25-2014 at 03:14 PM.
DOCTORBILL is offline   Reply With Quote
Old 05-24-2014, 08:40 PM   #20
Crvett69
AF Moderator
 
Crvett69's Avatar
 
Join Date: Oct 2004
Location: Bellingham, Washington
Posts: 1,749
Thanks: 0
Thanked 73 Times in 73 Posts
Re: '93 Geo Metro Problem - Intermitant and Enigmatic

check second post on the 1st page
Crvett69 is offline   Reply With Quote
Old 05-26-2014, 06:18 PM   #21
DOCTORBILL
Geo Metro Lover
Thread starter
 
DOCTORBILL's Avatar
 
Join Date: May 2005
Location: Eastern Washington State, Washington
Posts: 1,617
Thanks: 0
Thanked 0 Times in 0 Posts
Re: '93 Geo Metro Problem - Intermitant and Enigmatic

Unless the missing starts up again, I think this posting will end this thread.
__________________

DOCTORBILL is offline   Reply With Quote
Old 10-08-2014, 06:47 PM   #22
ptcapboy
AF Newbie
 
Join Date: Jun 2013
Location: Port Townsend, Washington
Posts: 10
Thanks: 0
Thanked 1 Time in 1 Post
Re: '93 Geo Metro Problem - Intermitant and Enigmatic

Missed this post when it came out how is the Phoenix running now DoctorBill? Glad you were able to figure it out-have throughly enjoyed your past posts, especially LIFE AFTER DEATH RINGS-
ptcapboy is offline   Reply With Quote
Old 10-13-2014, 11:54 AM   #23
gas_saver
AF Newbie
 
Join Date: Oct 2014
Location: Springfield, Kentucky
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: '93 Geo Metro Problem - Intermitant and Enigmatic

I know it's a little late, but it could have been bad gas. Hard to check for that!
gas_saver is offline   Reply With Quote
Old 11-04-2014, 04:42 PM   #24
DOCTORBILL
Geo Metro Lover
Thread starter
 
DOCTORBILL's Avatar
 
Join Date: May 2005
Location: Eastern Washington State, Washington
Posts: 1,617
Thanks: 0
Thanked 0 Times in 0 Posts
Re: '93 Geo Metro Problem - Intermitant and Enigmatic

It was a "bad" distributor, for sure !

Crvett69 predicted it was the distributor and sure enough, he was right.

The Phoenix runs perfectly now.
It is just slowly rusting away.
Soon I'll be driving the frame around w/o any body.

The krap they put on the roads in Spokane, WA to melt the snow
and Ice eats cars up for breakfast.

You need a car made of Platinum.

DB
__________________

DOCTORBILL is offline   Reply With Quote
Old 11-29-2014, 06:20 PM   #25
ptcapboy
AF Newbie
 
Join Date: Jun 2013
Location: Port Townsend, Washington
Posts: 10
Thanks: 0
Thanked 1 Time in 1 Post
Re: '93 Geo Metro Problem - Intermitant and Enigmatic

yeah as far as my metro is concerned I'm lucky to live on the west side of the cascades-less salt on the roads over here-
ptcapboy is offline   Reply With Quote
Old 11-29-2014, 10:52 PM   #26
Crvett69
AF Moderator
 
Crvett69's Avatar
 
Join Date: Oct 2004
Location: Bellingham, Washington
Posts: 1,749
Thanks: 0
Thanked 73 Times in 73 Posts
Re: '93 Geo Metro Problem - Intermitant and Enigmatic

im on this side of them too and only metros i see with rust come down from canada or east coast usually. i get metro bodies in all the time Dr Bill. you could always get one with a bad motor and put yours into it or look for one over there with same issue but less/no rust and swap it
Crvett69 is offline   Reply With Quote
Old 11-30-2014, 01:02 PM   #27
DOCTORBILL
Geo Metro Lover
Thread starter
 
DOCTORBILL's Avatar
 
Join Date: May 2005
Location: Eastern Washington State, Washington
Posts: 1,617
Thanks: 0
Thanked 0 Times in 0 Posts
Re: '93 Geo Metro Problem - Intermitant and Enigmatic

No....I am too old to be doing things like swapping parts between two Metros.

When (if) this old Phoenix finally dies, I am thinking of looking into a used Suzuki Swift.

I have a lot of respect for Suzuki cars.

DoctorBill
__________________

DOCTORBILL is offline   Reply With Quote
Old 11-30-2014, 02:21 PM   #28
Crvett69
AF Moderator
 
Crvett69's Avatar
 
Join Date: Oct 2004
Location: Bellingham, Washington
Posts: 1,749
Thanks: 0
Thanked 73 Times in 73 Posts
Re: '93 Geo Metro Problem - Intermitant and Enigmatic

if you change your mind it is one of the easiest ones to do. a straight engine swap takes me about 3.5-4 hours
Crvett69 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Geo > Metro

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:34 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts