Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Geo > General Discussion
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 10-20-2004, 04:16 PM   #1
fiddler1
AF Newbie
 
Join Date: Oct 2004
Location: harrisville, New York
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
noise in front when turning right on take off!!

When i take off usually after warmed up,i get a noise when turning to the right,wondering if it could be a motor mount?? ant other ideas??
P.S. this is a 1992 geo prizm!
fiddler1 is offline   Reply With Quote
Old 11-10-2005, 02:39 PM   #2
myproblem
AF Newbie
 
Join Date: Aug 2005
Location: Bassett, Virginia
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Re: noise in front when turning right on take off!!

Could be a CV axle. I just recently installed on it would make a clicking sound
myproblem is offline   Reply With Quote
Old 12-29-2005, 05:29 PM   #3
joellthomas
AF Regular
 
Join Date: Jan 2004
Location: Vidalia, Georgia
Posts: 206
Thanks: 0
Thanked 0 Times in 0 Posts
Re: noise in front when turning right on take off!!

wheel bearing
joellthomas is offline   Reply With Quote
Old 04-02-2009, 12:29 AM   #4
crazzzyace08
AF Newbie
 
Join Date: Apr 2009
Location: Roseville, California
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Re: noise in front when turning right on take off!!

I have a 96 prizm and just replaced the right front hub assembly cuz the bearings where shot. but now ive got a horrid pulsing, grinding noise in the same area but it only happens when driving forward. it goes away when turning left or right. i had a gm mechanic look at it and hes baffled. any ideas?
crazzzyace08 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Geo > General Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:41 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts