Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Toyota > Land Cruiser/LX470
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 11-03-2008, 07:43 AM   #1
cliffordA
AF Newbie
 
Join Date: Nov 2008
Location: Raleigh
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Successfully Changed Both Pre-cat O2 Sensors!

I know this is a minor repair, but can you believe the dealership wanted over $700 to change both my pre-cat O2 sensors after the Malfunction Indicator Lamp (MIL) / Check engine Light went on?

Time spent was well worth the $500 saved.

Finished doing a write-up on it:
http://monkeeworks.com/go_O2



Thanks,
Clifford Vincent Arrow
monkeeworks.com
cliffordA is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Toyota > Land Cruiser/LX470

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:05 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts