Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Toyota > LS400/LS430/Celsior
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 05-08-2008, 05:36 PM   #1
KnoTT
AF Newbie
 
Join Date: May 2008
Location: Brisvegas
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Celcior Engine Problems ... Plz HELP !!

Hey Everyone,

So in short i have a celcior 90 model and recently it has started making a squeeking noise which is coming out of the engine. Now it doesnt make this noise all the time or at any particular time but when it does smoke starts to come out of the engine.

The noise kind of sounds like either a fanbelt or a metal rubbing on metal sound!!!

I was wondering what this could be or how i could figure out what it is ?

Hope you can help
KnoTT is offline   Reply With Quote
Old 05-18-2008, 01:02 PM   #2
Wil C
AF Newbie
 
Join Date: Apr 2007
Location: Hometown
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Celcior Engine Problems ... Plz HELP !!

Well.. I would see if it's actually the engine itself. Because if it was the engine.. and you kept running it.. i would expect your engine to seize up.

First i'll probably see if it happens only when it's cold. then see the belts condition, and see if the pulleys for the belt(s) is starting to seize or seized.(remember this could be any pulley, the alternator or someting in the timing belt(if you have one) or something.)

You need to better descibe this squeaking noise.. is it constant like non stop squeaking no matter what, or s it pulsing?(does it follow engine speed?)...

AND.. are you sure it's not brake wear indicators.. XD
Wil C is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Toyota > LS400/LS430/Celsior

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:06 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts