Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Ford > Bronco
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 05-08-2011, 09:21 PM   #1
bret112
AF Newbie
 
Join Date: May 2011
Location: Johannesburg, California
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
fuel electrical or brain problem

Heres a short version of the troubleshooting i have done and problems

fuel pumps dont run inertia switch is ok I put a hose in 1 gallon can and got siphon to high pressure fuel pump then hooked external battery to fuel pump. pump ran and got pressure in system. turned over engine and still wouldnt start. but when spraying starting fluid in for a few seconds it tried to start but acted like no fuel coming out injectors still only fired on starting fluid.
since when I turn key over the fuel pumps dont run and starting fluid gets it to fire would the problem be the brain and would the brain not let the fuel pumps and the injectors not operate.
I just bought this so I dont know the whole story of what happened to begin with and am working blind.
Also I tested both fuel pumps and replaced the low pressure pump already hi pressure worked fine.
any Ideas will help
thanks
bret112 is offline   Reply With Quote
Old 05-08-2011, 10:27 PM   #2
FishFind
One Hot Shot
 
Join Date: Mar 2010
Location: Venice, Florida
Posts: 444
Thanks: 29
Thanked 28 Times in 27 Posts
Re: fuel electrical or brain problem

Need the year and what car this is. Any light on dash>??? any security light>?
FishFind is offline   Reply With Quote
Old 05-08-2011, 10:41 PM   #3
bret112
AF Newbie
Thread starter
 
Join Date: May 2011
Location: Johannesburg, California
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: fuel electrical or brain problem

sorry 1988 ford bronco II 2.9 ltr no lights
bret112 is offline   Reply With Quote
Old 05-18-2011, 02:22 PM   #4
lilwhitelude
AF Newbie
 
Join Date: Dec 2004
Location: hot springs, Arkansas
Posts: 87
Thanks: 0
Thanked 1 Time in 1 Post
Send a message via AIM to lilwhitelude
Re: fuel electrical or brain problem

check to see if the fuel pump relay is sending power to the pump. If so. make sure power is getting down there. Make sure the plugs are firing. If so, use a noid light set and check to see if the injectors are getting voltage. If not, check grounds and power to pcm. Check the pcm fuses to make sure they are in good order. If so. have someone put a scanner on it and see if the pcm is communicating with it, if it is not, you might have a bad pcm, but check every other option before even thinking of replaceing the pcm
lilwhitelude is offline   Reply With Quote
Old 06-24-2015, 05:54 PM   #5
ShawnMcIntyre
AF Newbie
 
Join Date: Jun 2015
Location: Seabeck, Washington
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: fuel electrical or brain problem

Hi there I have an 87 Bronco II and it has been running great then I let my wife drive it. She was going along and it started losing power so she pulled over and shut it off. I went to her I started it but could not get RPMs to go up then it started running real rough and now it will turn over but not start. Can somebody give me and idea of where to start? I have owned this Bronco II for 24 years it is on it's second engine. My wife jokes I would get rid of her before it.
ShawnMcIntyre is offline   Reply With Quote
Old 01-11-2016, 11:14 PM   #6
jamo1234
AF Newbie
 
Join Date: Jan 2016
Location: questa, New Mexico
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: fuel electrical or brain problem

Found bared wires in harness running across top of power steering pump.
jamo1234 is offline   Reply With Quote
 
Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 xterra electrical/gauge problems greenman23 Pathfinder | Terrano | QX4 | Xterra | Patrol | Safari | X-Trail 1 03-15-2011 11:42 AM
85 grand marquis - electrical problem aray4al Grand Marquis 5 06-25-2010 06:39 PM
1999 Jetta GLS 2.0 AEG Fuel system problem Probe '97 - '03 3 04-20-2010 11:24 PM
New electrical issue Malacite69 Cavalier Problem Diagnosis 0 03-09-2010 03:33 PM
96 Bronco Fuel Tank Sending unit. mareco32 Bronco 1 09-06-2009 09:02 PM

Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Ford > Bronco

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:05 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts