Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Engineering/Technical
Engineering/Technical Ask technical questions about cars. Do you know how a car engine works?
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 05-29-2001, 12:51 AM   #1
Aki
AF Newbie
 
Join Date: May 2001
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Angry HELP! Engine/power loss!!!

I have a big problem losing power & revving too high. My car is automatic '93 Integra and has 150,000 miles on it. Lately, when I lightly push the gas after starting the engine, the car will move smooth sometimes but other times, the engine feels like it's choking or would rev-up to 5000rpm without going anywhere. Is this a transmission problem? Something I can check? Or something that's ready to go out!!! Please help. I want to keep this car but lately I'm losing too much power...
Aki is offline   Reply With Quote
Old 05-29-2001, 08:51 AM   #2
DVSNCYNIKL
R.I.P. DAD 3/25/11
 
DVSNCYNIKL's Avatar
 
Join Date: May 2001
Location: Mount Vernon, New York
Posts: 6,253
Thanks: 10
Thanked 6 Times in 6 Posts
Send a message via ICQ to DVSNCYNIKL Send a message via AIM to DVSNCYNIKL Send a message via Yahoo to DVSNCYNIKL
Sounds like maybe your transmission is slipping. You might want to have it checked by a mechanic or trans. specialist. You don't want it to go out in the most inopportune time.
__________________
Why do banks charge you a "non-sufficient funds fee" on money they already know you don't have?
DVSNCYNIKL is offline   Reply With Quote
Old 06-05-2001, 06:48 PM   #3
Steve
AF Newbie
 
Join Date: Mar 2001
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
The first thing I would check is the transmission fluid. If it is low it will slip.
Steve is offline   Reply With Quote
 
Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 Sienna Gummed Engine, Power Loss, Clicking Nebeno Sienna 3 07-17-2010 08:05 PM
Power Loss in an '89 4Runner toyotatech89 4Runner/GX470 6 08-07-2009 02:23 PM
engine power loss when a/c is on iamammon Bonneville 3 10-16-2003 09:57 PM

Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Engineering/Technical

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:49 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts