Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Cadillac > Deville
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 05-04-2020, 06:23 AM   #1
Terry Lindsey
AF Newbie
 
Join Date: Jan 2020
Location: Steubenville
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
04 Cadillac DeVille

Has anyone else that owns a 04 Cadillac DeVille had this problem? if so what did you do to fix? two days ago I went out and started the car so it can warm up cause it was a lil nippy that morning and I noticed that the climate control display was blank no digital readout but the funny thing is that the controls still work I can turn heat and AC on fan high or low ect I checked fuses there good is there something else that that I'm missing

Last edited by Terry Lindsey; 05-06-2020 at 07:52 PM. Reason: No response from anyone
Terry Lindsey is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD

Go Back   Automotive Forums .com Car Chat > Cadillac > Deville

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:59 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts