Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Suzuki > Sidekick
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 05-03-2004, 06:28 PM   #1
614mobile
AF Newbie
 
Join Date: May 2004
Location: Richmond, Virginia
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Question Sluggish performance

I have a 97 Sidekick that has lost its performance. It will get going but now it takes a while. I am going to change the fuel filter. The plugs look good. It doesn't smoke. I have run fuel injection cleaner through it. So far no difference. I would appreciate any ideas or suggestions. Thanks.
614mobile is offline   Reply With Quote
Old 05-03-2004, 07:03 PM   #2
1995 geo tracker
AF Enthusiast
 
1995 geo tracker's Avatar
 
Join Date: Dec 2003
Location: Rochester, New Hampshire
Posts: 295
Thanks: 0
Thanked 0 Times in 0 Posts
do a full tune-up on it and clean the TB , you might want to think about changing the 02 sensor
1995 geo tracker is offline   Reply With Quote
Old 05-03-2004, 07:32 PM   #3
614mobile
AF Newbie
Thread starter
 
Join Date: May 2004
Location: Richmond, Virginia
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks. I will do this tomorrow and post my results.
614mobile is offline   Reply With Quote
Old 08-08-2004, 06:34 PM   #4
suzukiesue
AF Newbie
 
Join Date: Aug 2004
Location: chesapeake, Ohio
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to suzukiesue
Re: Sluggish performance

Quote:
Originally Posted by 614mobile
I have a 97 Sidekick that has lost its performance. It will get going but now it takes a while. I am going to change the fuel filter. The plugs look good. It doesn't smoke. I have run fuel injection cleaner through it. So far no difference. I would appreciate any ideas or suggestions. Thanks.




Did you ever get it to run right what was the problem?I have the same problem with my 97 sidekick
suzukiesue is offline   Reply With Quote
Old 08-21-2004, 05:33 PM   #5
shconer
AF Newbie
 
Join Date: Nov 2002
Location: Calgary
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
i have a 93 sidekick with a 16v with similar problems. changing the filter problably wont help, i have tried that. i have 292000 km on mine. it has started to smoke on start up witch i belive is the result of worn out valve seals. it studers when it is warm and after periods of de accelaration and idle it gets worse the lower the fuel level. i also know that when it studers it is running lean. im coming to the conclution that valve seals are leaking during idle and creates a poor burn until its burned off, and or a combination of a failing fuel regulator and or fuel pump witch i have changed beforeand or injectors because fuel additives seam to help slightly.
shconer is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Suzuki > Sidekick

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:24 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts