Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Rolls Royce > Silver Series
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 03-21-2006, 03:39 PM   #1
pdbenson
AF Newbie
 
Join Date: Mar 2006
Location: Atlanta, Georgia
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Silver Shadow II 1978 Ignition Module ?

Can someone help me. I have a 1978 Silver Shadow II when I drive it, it's great runs perfect. All of a sudden there is a clicking sound in the fuse area and the yellow oil light turns on (oil pressure is good etc.), the air blower stops the compressor stops and I believe that the choke turns on and the car runs rough running rich, smells gassy, and turns off probably from the choke turning on. Does anyone have an idea what module or item is worn out? Seems to me that it is almost like something associated with the ignition switch, when your key is turned but not yet in crank mode is activating for no reason while driving. any ideas? Thank you in advance!
pdbenson is offline   Reply With Quote
Old 05-05-2006, 08:13 AM   #2
Nobleman
AF Newbie
 
Join Date: May 2006
Location: Blytheville, Arkansas
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Cool Re: Silver Shadow II 1978 Ignition Module ?

Hello pdbenson,
Just a suggestion:
You may want to try running the vehicle with the oil pressure warning light disconnected at the sender end..that's at the front of the engine on the "B bank" side (left) near the crankshaft pulley...I believe it's the top one of the two senders that are located there (if memory serves well, without having to slide under my car...), either way, it's the smallest of the two. Disconnect the wire and run the car normally and see what happens.
The oil pressure "idiot light" (you'll still have the gauge) is connected to fuel pump supply voltage circuit, so in the event of an accident or whatever, to prevent fuel pump running if motor is stopped (0 oil pressure).... this sender can go faulty (it did in one of my cars) and cut your fuel supply off when it goes goes bad and erroneously senses no oil pressure.
Just any cheap GM type sender from autoparts store is a good replacement if you find that it is faulty and the car runs problem free.
Let us know how you get on.
Nobleman
Nobleman is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD

Go Back   Automotive Forums .com Car Chat > Rolls Royce > Silver Series

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:24 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts