Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Oldsmobile > Achieva
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 01-12-2011, 04:49 PM   #1
krystar
AF Newbie
 
Join Date: Jan 2011
Location: omaha, Nebraska
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation 97 oldsmobile achieva sl overheated and now it wont start please help!!!!!!!!!

my 97 oldsmobile achieva started overheating today and smoke came inside the car and out , antifreeze came out of the reserve and it was starting fine but now it wont even start , someone told me it was the thermastat , but will that cause the car not to start???what is wrong??Please help!
krystar is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Oldsmobile > Achieva

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:13 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts