Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Oldsmobile > Achieva
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 02-16-2015, 03:29 PM   #1
jerseylady
AF Newbie
 
Join Date: Feb 2015
Location: newark, New Jersey
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
95 Achieva shuts itself off

Hi,

I'm hoping I can get an idea about what might be wrong with my car before the mechanic looks at it and possibly rips me off.
The car was sitting for about a month in cold weather. A battery was put in and after a bit of hesitation it started and I used it for a day. Seemed fine. That night I tried to start it and it took three tries and then died before I could put it in drive. Got it started again and it was okay for the short drive home.
Today it started after a couple of tries, but turned itself off again after a couple of minutes in park and then the dash said "hot" and "charge battery". But the battery is brand new. I know nothing about cars so any opinions or advice would be appreciated.
jerseylady is offline   Reply With Quote
Old 02-16-2015, 06:11 PM   #2
Tech II
AF Fanatic
 
Join Date: Jul 2011
Location: Worcester, Massachusetts
Posts: 5,017
Thanks: 70
Thanked 617 Times in 609 Posts
Re: 95 Achieva shuts itself off

Is the alternator charging? Do you have a voltmeter?

With nothing on, battery should measure 12.6 volts.....after it starts, it should be 13.5-14.5 volts...

Does it say hot while it is running? have you checked the coolant level in the radiator and reservoir(should be done on a cold engine, before starting)?
Tech II is offline   Reply With Quote
Old 02-18-2015, 03:56 PM   #3
jerseylady
AF Newbie
Thread starter
 
Join Date: Feb 2015
Location: newark, New Jersey
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 95 Achieva shuts itself off

Sorry, I don't know the answer to the first question, but I don't have a voltmeter.

I recently added coolant because there had been a small leak. I believe it said hot and charge battery just after it shut off. It only happened once.
jerseylady is offline   Reply With Quote
Old 02-18-2015, 04:22 PM   #4
Tech II
AF Fanatic
 
Join Date: Jul 2011
Location: Worcester, Massachusetts
Posts: 5,017
Thanks: 70
Thanked 617 Times in 609 Posts
Re: 95 Achieva shuts itself off

When a car dies, idiot lights come on.......

You need to know if the car is charging......does the dash have a voltage gage? If no, when it starts and runs, is the BAT light on?

You need to check for codes also....

If the car cranks over ok, but doesn't start, get a can of carb cleaner...outside air has to be over 32F....spray into the throttle body while someone cranks the vehicle....if it starts and runs as long as you spray, you have a fuel delivery problem, either fuel pressure is low(pump) or injectors aren't firing....

Which engine is this? 3.1 or 2.4?
Tech II is offline   Reply With Quote
Old 02-28-2015, 11:11 AM   #5
jerseylady
AF Newbie
Thread starter
 
Join Date: Feb 2015
Location: newark, New Jersey
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 95 Achieva shuts itself off

Sorry I didn't get back sooner. The mechanic said it most likely shut itself off to prevent overheating from low coolant, there is probably a leak. And it needs a tune up. It seems to be working ok so far. Thanks for trying to help.
jerseylady is offline   Reply With Quote
Old 03-04-2015, 12:08 PM   #6
Tech II
AF Fanatic
 
Join Date: Jul 2011
Location: Worcester, Massachusetts
Posts: 5,017
Thanks: 70
Thanked 617 Times in 609 Posts
Re: 95 Achieva shuts itself off

Cars do not shut off to prevent overheating....
Tech II is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Oldsmobile > Achieva

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:49 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts