Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Ford > Escape | Maverick | Escape Hybrid
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 03-12-2015, 08:08 PM   #61
rosemont
AF Newbie
 
Join Date: Mar 2015
Location: Frederick, Maryland
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Oil pressure light was blinking at idle; now constant

I am seeing the exact symptom on wife's Ford Fusion 2008 SEL V6 3.5L. It started right after an oil change. Could be coincidental.

I would be very curious to learn how is the original poster dylanborns's car running at this time, even if a cure has not been found.
rosemont is offline   Reply With Quote
Old 03-13-2015, 07:26 AM   #62
dylanborns
AF Regular
Thread starter
 
Join Date: Jul 2009
Location: Grain Valley, Missouri
Posts: 106
Thanks: 1
Thanked 0 Times in 0 Posts
Re: Oil pressure light was blinking at idle; now constant

Quote:
Mine it was the pickup screen in the oil pan was 90% clogged. Dropping the pan with the exhaust manifold to exhaust nuts corroded away was a pain, but putting it back with a nice seal that no longer leaked and no more oil light till the pump gave way at 180,000 was nice.
This maybe something I will try to tackle in the near future. I haven't dropped the pan to check the screen.

Quote:
I would be very curious to learn how is the original poster dylanborns's car running at this time, even if a cure has not been found.
I went through three different oil pressure sensors and all did the same thing, so I don't think its just a bad sensor. I'm at 144,000 miles so I'm wondering if the bearings are wearing on the motor. I ended up just going with a thicker oil, which my mechanic said was okay to do anyway. He said he uses the thinner oil in the winter, and switches over to thicker in the summer on all his cars no matter what the manufacturer recommends.
Since I've been running the thicker oil, I haven't had any oil pressure issues. If this is happening on your '08, I would investigate it alot further since its such a newer car compared to mine.
dylanborns is offline   Reply With Quote
Old 03-30-2015, 08:21 AM   #63
wilyrose
AF Newbie
 
Join Date: Mar 2015
Location: Frenchburg, Kentucky
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Oil pressure light was blinking at idle; now constant

What weight oil did you end up going to. My wife's 2001 Escape just started doing the same thing. We changed to 10w30 several years ago. I'm having a new switch installed tomorrow and I'm thinking about going to 40 weight if that doesnt fix it.
wilyrose is offline   Reply With Quote
Old 03-30-2015, 10:01 AM   #64
65comet
AF Enthusiast
 
65comet's Avatar
 
Join Date: Aug 2004
Location: Porter, Indiana
Posts: 801
Thanks: 7
Thanked 65 Times in 63 Posts
Re: Oil pressure light was blinking at idle; now constant

Heavier oil is ok if the weather is warm. In Kentucky you don't get enough cold to worry about changing back in the winter. My 85' VW Golf Cabriolet runs 20W50 in the summer. But up here, when the real cold starts, I bring it back to 10W30 or it gets to thick to crank in the morning. I never ran heavier oil in my Escape even when the oil light started the flicker issue than 10W30.
65comet is offline   Reply With Quote
Old 03-30-2015, 07:28 PM   #65
dylanborns
AF Regular
Thread starter
 
Join Date: Jul 2009
Location: Grain Valley, Missouri
Posts: 106
Thanks: 1
Thanked 0 Times in 0 Posts
Re: Oil pressure light was blinking at idle; now constant

I've used 10w-30 since I started the post and the light has not come back on. I'm at 145000 miles and I'm assuming the bearings are wearing, but the heavier oil has helped.
dylanborns is offline   Reply With Quote
Old 01-24-2016, 04:48 PM   #66
FrustratedWFords
AF Newbie
 
Join Date: Jan 2016
Location: Fort Worth, Texas
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Oil pressure light was blinking at idle; now constant

Our 2005 Ford Escape, V6, would so similar. Low Oil Pressure lite on after warm up, pulling into the garage. Engine runs fine, no noise, etc. We do have some oil leaks on the passenger side, par for the course with Fords.

Anyway, had the oil pressure sensor/switch replaced with Ford OEM and comes on a bit less, but still comes on. So, installed a manual (analog) gage where the switch went. Lowest oil pressure I have seen thus far is around 14 PSI in drive/foot on brake, about 600-650 RPM (on the car's gage). Per the garage, they want to sell me a new motor for $6K. Can't afford that. I added some 10W40 synthetic oil to top it off and they said not to do that as the oil ports in the pump are very small and the heavier oil won't flow thru there. With 6 quarts of oil in this car, I hardly think 1/3 of one quart will hurt.

Oddly enough, I have called the Ford Dealership, garages, etc. "what is the minimum oil pressure for this car to be considered "low" pressure. No one knows. One friend that races cars told me generally around less than 10 PSI. So with idle in the 600-700 range, 133K miles, it may come on as some wear to the car but 133K isn't high mileage these days.

So, have no idea. Oil is always clean, 3K mileage oil changes, 20W last time, will go back to 5W20 per the filler cap and see what happens. Someone said to run flush in it before the oil change but no shop will do that, so not sure if I should dump a can in the motor, and then run up for an oil change. Use to be the thing to do to clean out crap out of the motor. So, still at a loss. Keep driving I suppose until it poops out, and then would need a motor. Being 10 years old, I doubt I would want to spend $6K on a new motor, $3.5K on a used one with 1 year warranty.
FrustratedWFords is offline   Reply With Quote
Old 01-24-2016, 04:52 PM   #67
FrustratedWFords
AF Newbie
 
Join Date: Jan 2016
Location: Fort Worth, Texas
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Oil pressure light was blinking at idle; now constant

Just what exactly is the "low Oil Pressure" threshold for a V6 Escape? From what I am reading, makes me think back to older cars where when they got over 100K miles, you just drove them and didn't work about some idiot light, you had a pressure gage and if it got low, you added oil or just heavier oil and all was well for around another 100K miles. They you started to think about selling, rebuilding, swapping motors, perhaps. I really don't see less than 150K miles as "high mileage" unless you don't take care of your car and the "don't use heavier oil" scare tactic by some garages is bogus. I am thinking no one in the auto industry really knows what that threshold is....
FrustratedWFords is offline   Reply With Quote
Old 01-25-2016, 07:14 PM   #68
FrustratedWFords
AF Newbie
 
Join Date: Jan 2016
Location: Fort Worth, Texas
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Oil pressure light was blinking at idle; now constant

I can't believe that there are that many Escapes running around out there that when they hit 100K miles, suddenly, there is an oil pressure issue. Possibly but sure sounds hokey to me. I think Ford put an idiot light on the car with either too tight a spec/threshold to get owners to pony up for new motors or something. I keep thinking back to older cars I have had, being a quart low, or whatever, you found that out when you checked the oil on the dip stick, no idiot light, nothing.

I still can't find anywhere what the "low pressure" limit/threshold is. A friend who races car said the standard they used was 10 psi or lower and another chap told me below 5PSI. When the car is at idle at a stop sign, in drive, you aren't really running many RPMs or rotations so I am thinking perhaps that lower pressure is normal vs so many cars with bearing problems, oil pump failures, etc. I never heard of oil pump failures until this car, and bearing issues were in cars (vehicles) over 200K or more. Sure sounds strange to me and can' t get one answer.
FrustratedWFords is offline   Reply With Quote
Old 08-20-2016, 09:35 AM   #69
Rocker100
AF Newbie
 
Join Date: Aug 2016
Location: Mooresville, North Carolina
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
01 Ford Escape V6 3.0

Hey guys, I stumbled across this forum after i did a google search for the same problem. My wifes escape has 256k on it and it still runs great, however the oil light flickering at this mileage has worried me a little. This started around a year ago, so i keep the oil and filter fresh always using motorcraft oil and filters. I notice that for the first 1000ish miles after an oil change there is no light issues. After that we get a little flicker usually only at idle in drive with brake applied. Under a load. Sometimes it'll come on in park not often tho. A few changes ago i substituted a quart of good ole' motorcraft 5w20 for a quart of lucas oil stabilizer. This seemed to help stop the flashing filament for around 2000 miles after an oil change. I have not hooked up a gauge, or R2ed my oil psi switch. I've talked to several ASE techs and the common thing i hear is bearing clearances are widening which makes sense for my vehicle and the mileage on it. I am hesitant to add anything other than lucas to the oil, I'd hate to cause damage to the engine by adding a solvent that was supposed to clean but ended up breaking off a chunk of sludge or grime and clogging a port or the pump. Anyway like I said we've been driving this way for about a year and the oil always looks ok coming out, a little black but no alarming metallic objects or flakes, that may be just a good oe filter though. Good luck everybody. Hope I helped somebody here. Any new things i try, I'll post here for better or for worse.
Rocker100 is offline   Reply With Quote
Old 02-24-2017, 04:47 PM   #70
mrios
AF Newbie
 
Join Date: Feb 2017
Location: Calexico, California
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up Re: Oil pressure light was blinking at idle; now constant

Hello:
Mine is a Ford Escape 2003 V6 3.0L, same problem.
RootCause: When the catalizer converter was changed, a bold was no tigthen, so hot gas escapes from this and "wasboiling" the oil pan, so replace the bold and tigthen and problem solved.
Regards.
mrios is offline   Reply With Quote
Old 05-11-2017, 09:55 AM   #71
JBurn244
AF Newbie
 
Join Date: May 2017
Location: Liberty
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Oil pressure light was blinking at idle; now constant

Been doing some reading online as this just started happening to me...07 Escape, V6, about 146K miles. I'm a little worried because I went around 5-6k between my last oil change, so I'm hoping the bearings didn't enter into the noticeable wear threshold in the time.

The light started flickering on, so I was thinking that maybe she was running low, so I went straight to the oil change place. But of course it kept happening inline with the same symptoms noted here.

Only at idle, RPMs are fine at around 700RPM. Only happens in Drive, goes off immediately in Neutral or Park. The engine runs fine, if oil pressure was low it seems like it would be pretty obvious at idle. If there was no light, I would not suspect a thing.

I am going to change the pressure switch and hope that fixes it.

Anyone have any updates?
JBurn244 is offline   Reply With Quote
Old 05-18-2017, 05:26 PM   #72
rhandwor
AF Enthusiast
 
Join Date: Sep 2006
Location: Athens, Georgia
Posts: 4,640
Thanks: 0
Thanked 63 Times in 63 Posts
Re: Oil pressure light was blinking at idle; now constant

I would use a manual gage and determine the actual oil pressure. At this point I would decide what to do to correct the problem.
rhandwor is offline   Reply With Quote
Old 12-30-2017, 09:17 PM   #73
Macmommy
AF Newbie
 
Join Date: Dec 2017
Location: Lexington, North Carolina
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Oil pressure light was blinking at idle; now constant

Found this thread as many of you have by searching for info on an oil light flickering on a Ford Escape.
I'm curious to know what happened with dylanborns vehicle, ultimately.
Ours is a 2002 Ford Escape, fresh oil change with 5w20 synthetic, new plugs, valve cover gaskets, new oil pressure sensor/switch, etc.
Macmommy is offline   Reply With Quote
Old 01-03-2018, 09:06 PM   #74
Mustang_Driver
AF Regular
 
Join Date: Sep 2013
Location: Surrey BC Canada
Posts: 133
Thanks: 0
Thanked 3 Times in 3 Posts
Re: Oil pressure light was blinking at idle; now constant

I too am having an intermittent oil light flicker at O/T in drive at stop lights light ultimately goes out once i tap gas pedal and will stay out for awhile and come back on at a later time.. Funny thing is all this started happening after and i mean after FORD dealership changed my fluids after i bought the vehicle.

i bought the vehicle in may last year drove it till august never had an issue had the fluids changed and all hell broke loose and it has been parked pretty much since. i have only put approx 1500km on it since i bought it but after ford touched it, i have had a bad o2 sensor(wasn't to do with ford) then FLUSHED my transmission and all of a sudden i have a 3-4 gear flare (rpm's rev 1000 more before slamming into o/d) and that was a costly fix at the tune of $3100.00 and after the oil was changed they put 5w20 synthetic blend in it i have a flickering oil light so if i decide to keep this vehicle i may have the motor rebuilt but before dumping another 3-4000 dollars into this vehicle i may as well buy a new one i would like to know if anyone got their issue fixed .. and the solution... i did buy a new sending unit but it just got too cold to play around with it and we still have ice in the driveway
__________________
1999 SVT Cobra Convert. - Sold 120000 KM
1998Mustang GT - Sold 118000 KM
2008 Ford Focus SE - BLOWN HEADGASKET 60000km (Not Ford's proudest moment and out of warranty so i let the bank have it)
2001 Ford Windstar SE - Bought to be able to haul a wheelchair (132000KM) Trans packed it in at 142000km 2001 Ford Windstar Sport Bought to replace the SE and got a decent deal on it (136000KM) but decided to keep both vans as there seems to be many issues and i can alternate
Mustang_Driver is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Ford > Escape | Maverick | Escape Hybrid

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:23 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts