Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Hummer (AM General) > Hummer H3
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 09-18-2015, 01:18 PM   #1
OffRoad87
AF Newbie
 
Join Date: Sep 2015
Location: Pasadena, Texas
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation H3 transmission

2006 H3 120k miles

I had smelt some burning while I had stopped at the store. When I drove it back home it made some kind of weird noise. After it cooled down I checked under the hood and found out the dipstick tube to the transmission had a hole in it and the transmission had no fluid in it or at least VERY LOW. I'm waiting on the part to come in. When I replace the tube and refill the transmission fluid do you guys think it will still run or did I mess up the transmission by driving it like that? It was only about 40 miles or so. Anyone have had this problem happen to them?
OffRoad87 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Hummer (AM General) > Hummer H3

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:50 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
 
no new posts