Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > MG > MG ZR/ZS/ZT
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 02-23-2006, 12:26 PM   #1
kat1908
AF Newbie
 
Join Date: Feb 2006
Location: manchester
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
:s

just changed spark plugd in mg zr cos it was tryin to stall at set of so tohught that might do it. new sparks have made it worse booked in foe service but just wonderd if any one got any advice
kat1908 is offline   Reply With Quote
Old 12-02-2014, 06:40 AM   #2
CmannP
AF Newbie
 
Join Date: Nov 2014
Location: Epsom
Posts: 11
Thanks: 1
Thanked 0 Times in 0 Posts
Re: :s

Have you checked your starter motor? That was what killed my ZR in the end. It became so rusted and corroded that it just fell apart basically. When I tried replacing it myself the nuts were fused and some of the wiring basically fell apart in my hands. Had to scrap her after. I hope your issue doesn't end the same way but it's definitely worth looking at.
CmannP is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > MG > MG ZR/ZS/ZT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:54 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts