Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Jaguar > XK | XKR | XXR-S
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 05-30-2004, 01:41 AM   #1
Spitz
AF Newbie
 
Join Date: May 2004
Location: Prince Albert
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Carbs

My brother just took delivery of a 1973 2+2 V12 e-type.
He's not mechanically inclined...I am somewhat.
I checked his carbs and they all had very little trace of oil in the dashpot. I am familiar with SU carbs, but not Stromberg's. (I'm assumming it's the same theory).....I filled then to just below the theads with ATF. The car seems to bog down when the initially accelerating.
Should I be using a thicker/thinner oil? Have I used too much oil..?
Secondly.....Ive never heard..let alone driven a V12. The sound at idle was a sound I didn't expect. It sounds like a 6 cyl. Could one side of the exhaust be plugged...? (I didn't think to put my ear down to the pipes).

Thanks for any replies...excuse my nievety..
Cheers
Spitz is offline   Reply With Quote
Old 12-06-2004, 10:04 PM   #2
E-Type
AF Newbie
 
Join Date: Dec 2004
Location: Cumberland, Rhode Island
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Carbs

Quote:
Originally Posted by Spitz
My brother just took delivery of a 1973 2+2 V12 e-type.
He's not mechanically inclined...I am somewhat.
I checked his carbs and they all had very little trace of oil in the dashpot. I am familiar with SU carbs, but not Stromberg's. (I'm assumming it's the same theory).....I filled then to just below the theads with ATF. The car seems to bog down when the initially accelerating.
Should I be using a thicker/thinner oil? Have I used too much oil..?
Secondly.....Ive never heard..let alone driven a V12. The sound at idle was a sound I didn't expect. It sounds like a 6 cyl. Could one side of the exhaust be plugged...? (I didn't think to put my ear down to the pipes).

Thanks for any replies...excuse my nievety..
Cheers

Hi Spitz:

Do not use ATF in the Strombergs, use straight 30 weight oil.

As far as the sound goes you probably have the 4 port exhaust, which usually sounds a sweet note. The first thing that I would suggest is that you replace the plugs, and check the spark plug wires for dry rots. If they are old or heat corroded, you might experience problems.

Good luck and have a ball with your baby!!!

Regards,

E-Type
E-Type is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Jaguar > XK | XKR | XXR-S

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:01 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts