Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Hummer (AM General) > Hummer H3
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 10-25-2012, 10:19 AM   #1
onerobertone
AF Newbie
 
Join Date: Jul 2007
Location: Harrisburg, Pennsylvania
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
H3 Transmission

2010 H3 68,000 miles. 5 cycl.

I was 4 hours into a 6 hour trip. We stopped to grab a soda, got back in and then the transmission get like it would slip at about 3,000rpm.

Once we got home and I let it sit for a few hours it didn't do it anymore. I still took it to the garage and they said there were no codes thrown and since it wasn't doing it there was nothing that could do.

Now while it doesn't do it it does every once in awhile feel like it slip while making a right turn.

Weird right. Anybody got anything?
onerobertone is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Hummer (AM General) > Hummer H3

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:37 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts