Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Ford > Explorer | Explorer Sport Trac
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 04-23-2004, 12:06 PM   #1
ky_horsetrainer
AF Newbie
 
Join Date: Apr 2004
Location: Tyner, Kentucky
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Question Tachometer, fuel gauge, oil pressure gauge not working.

I have a 92 explorer. the gauges and tachometer are not working but the spedometer is

any suggestions?

P.S. checked all fuses
ky_horsetrainer is offline   Reply With Quote
Old 04-26-2004, 01:49 AM   #2
amac209
AF Enthusiast
 
Join Date: Feb 2004
Location: fairbanks, Alaska
Posts: 921
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to amac209
Re: Tachometer, fuel gauge, oil pressure gauge not working.

remove the cluster, unplug it and clean the conection then plug it back in. if that doesn't fix it check the grounds under the dash. it's also possible theres a problem with the cluster, i'm pretty sure you have a printed circuit on the back of the cluster, look for any corosion or burnt circuits. good luck hopefully it's something simple
amac209 is offline   Reply With Quote
Old 04-26-2004, 08:40 AM   #3
ky_horsetrainer
AF Newbie
Thread starter
 
Join Date: Apr 2004
Location: Tyner, Kentucky
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
i got it fixed. it was the some crossed wires.
ky_horsetrainer is offline   Reply With Quote
Old 05-02-2004, 01:36 PM   #4
jits7
AF Newbie
 
Join Date: Apr 2004
Location: dun, Ohio
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
i have the same problem which wires are crossed? thanks
jits7 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Ford > Explorer | Explorer Sport Trac

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:30 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts