Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Engineering/Technical
Engineering/Technical Ask technical questions about cars. Do you know how a car engine works?
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 02-24-2011, 02:56 PM   #1
Tearl99
AF Newbie
 
Join Date: Feb 2011
Location: Santa Maria, California
Posts: 3
Thanks: 1
Thanked 0 Times in 0 Posts
the engine just shut off

I have a 67 Cameo with a 350 engine and a Mallory Distributors. My problem after driving around town for about forty five minutes the engine just shut off. This happened twice. This time I let the car cool down, about two hours and the engine started. I have noticed in the last couple of weeks, the engine temp is constantly around 180 deg. Then when the car is turned off the temp goes up around 190 deg. Any ideas
Tearl99 is offline   Reply With Quote
Old 02-24-2011, 03:53 PM   #2
Scrapper
AF Premium User
 
Join Date: Dec 2004
Location: Clarks Hill, Indiana
Posts: 2,724
Thanks: 0
Thanked 28 Times in 28 Posts
Re: the engine just shut off

67 camaro i had one and wish i still had it it was bad as. so anyway it won't crank when it dies? and temp will go up on all cars after you turn them off. check the spark when it wont start because it just may be the coil you put in and may be bad or need hotter coil?
Scrapper is offline   Reply With Quote
The Following User Says Thank You to Scrapper For This Useful Post:
Tearl99 (02-24-2011)
Old 02-24-2011, 04:18 PM   #3
Tearl99
AF Newbie
Thread starter
 
Join Date: Feb 2011
Location: Santa Maria, California
Posts: 3
Thanks: 1
Thanked 0 Times in 0 Posts
Re: the engine just shut off

The engine will turn over but wont start. the coil is less then 1 year old. Its is funny I can drive around for short times all day as long as the car can cool off I have no problem
Tearl99 is offline   Reply With Quote
Old 02-24-2011, 04:25 PM   #4
inafogg
AF Enthusiast
 
Join Date: Jul 2007
Location: claymont, Delaware
Posts: 1,745
Thanks: 10
Thanked 57 Times in 56 Posts
Re: the engine just shut off

converted to hei???sounds like ignition module heating up
try heating w/hair dryer to see if you get a no start condition
__________________
Live For Today
Yesterday is gone,
Tomorrows are'nt promised.
inafogg is offline   Reply With Quote
Old 02-24-2011, 11:13 PM   #5
Tearl99
AF Newbie
Thread starter
 
Join Date: Feb 2011
Location: Santa Maria, California
Posts: 3
Thanks: 1
Thanked 0 Times in 0 Posts
Re: the engine just shut off

I have been told befor that the HEI systems are proned to heat problems.
I will try the blow dryer and get back.
Thanks
Tearl99 is offline   Reply With Quote
Old 02-25-2011, 08:53 AM   #6
MrPbody
AF -Advisor
 
Join Date: Feb 2004
Location: Chesterfield, Virginia
Posts: 2,549
Thanks: 0
Thanked 6 Times in 5 Posts
Re: the engine just shut off

Before "pointing fingers" at what MIGHT be wrong, let's do some basic diagnostics.

Have you verified there is no spark when it won't fire? Have you verified there IS plenty of fuel?

If there's no spark, must verify there's "source" voltage still getting to the coil and distributor. You say "Mallory distributor", yet another speaks of HEI. Which is it? If a Mallory "Unilite", we've seen them do this, but usually they don't "come back". The modules are very sensitive to electronic "noise".

The only time we've seen HEI modules "drop out" is when they were ancient or "cheapo". It's not a "characterisitic" of the factory stuff. MSD makes a wonderful performance replacement, just in case...

Often, when higher temps come into the picture, fuel supply can be the culprit. A fuel pressure test is called for, specifically when the problem "occurs". Check the filter, too.

The temperature goes "up" when you shut it off due to "latent" heat. It's normal.

FWIW

Jim
MrPbody is offline   Reply With Quote
Old 02-26-2011, 10:58 AM   #7
Scrapper
AF Premium User
 
Join Date: Dec 2004
Location: Clarks Hill, Indiana
Posts: 2,724
Thanks: 0
Thanked 28 Times in 28 Posts
Re: the engine just shut off

Quote:
Originally Posted by MrPbody View Post
Before "pointing fingers" at what MIGHT be wrong, let's do some basic diagnostics.

Have you verified there is no spark when it won't fire? Have you verified there IS plenty of fuel?

If there's no spark, must verify there's "source" voltage still getting to the coil and distributor. You say "Mallory distributor", yet another speaks of HEI. Which is it? If a Mallory "Unilite", we've seen them do this, but usually they don't "come back". The modules are very sensitive to electronic "noise".

The only time we've seen HEI modules "drop out" is when they were ancient or "cheapo". It's not a "characterisitic" of the factory stuff. MSD makes a wonderful performance replacement, just in case...

Often, when higher temps come into the picture, fuel supply can be the culprit. A fuel pressure test is called for, specifically when the problem "occurs". Check the filter, too.

The temperature goes "up" when you shut it off due to "latent" heat. It's normal.

FWIW

Jim
i agree that msd are good coils as my wife makes them in lafayette in. they also make coils for harleys and some air plains.
Scrapper is offline   Reply With Quote
Old 02-26-2011, 03:19 PM   #8
MagicRat
Nothing scares me anymore
 
MagicRat's Avatar
 
Join Date: Dec 2003
Location: City of Light
Posts: 10,700
Thanks: 12
Thanked 79 Times in 74 Posts
Re: the engine just shut off

Quote:
Originally Posted by Tearl99 View Post
the engine temp is constantly around 180 deg. Then when the car is turned off the temp goes up around 190 deg. Any ideas
I'm assuming you have a mechanical temp gauge. This temperature behaviour is normal, particularly if you are using a port in the head for the sender.
MagicRat is offline   Reply With Quote
 
Similar Threads
Thread Thread Starter Forum Replies Last Post
"Help " Engine just shuts off venado Ram Pickup | Ram SRT10 7 03-31-2006 11:03 AM
98 Malibu-Engine just Shuts-off Hairy Dog Malibu 0 12-23-2004 06:15 AM
radio just shut off... anti theft light is blinking Moco64 Accord/TSX/Accord Hybrid 2 09-22-2004 06:33 PM
HELP!! my 99taurus SE just shut off.. zazo Taurus | Taurus Wagon 3 06-21-2004 01:30 PM
99 gtp stalling, just shutting off babyjuice Grand Prix 0 08-04-2003 10:52 PM

Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Engineering/Technical

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:45 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts