Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Cadillac > Brougham
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 04-01-2008, 01:22 PM   #1
mike lofgren
AF Newbie
 
Join Date: Apr 2008
Location: Tualatin, Oregon
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
1990 Brougham nstrument cluster goes out

Hi Everyone,

I have a 1990 Brougham and the instrument cluster goes black or dark. When I gently smack the dashboard the instrument cluster comes back on and stays on for several days only to go black again. Another smack and it is back on.

Also, the clock and radio display and the temperature display go off and on, but will flash when the turn signal is going. Sometimes radio and temperature displays are on when the instrument cluster is off but they are always on if the instrument cluster is working.

Any ideas what is causing this and how to correct it?

Thanks,


Mike
mike lofgren is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Cadillac > Brougham

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:23 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts