Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Mercury > Mountaineer
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 05-19-2018, 01:28 PM   #1
joe rope
AF Newbie
 
Join Date: Jan 2004
Location: chicago, Illinois
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
2007 mountaineer missing badly

I bought this auto at the auction (sight unseen) auto started but missed badly I thought it may need a tune-up but after that still missing I can drive the auto but it takes alot of time to reach 40mph it drags slowley... the obd codes read the throttle pedal needs to be replaced(did that) 136.00)no soap also says camshaft sensor bad... now this 4.0 sohc motor haves two timing chains the one in the rear of motor is the one i need to know if it is loose or what ? the car starts on the first starter turnover I thought that meant that the timing was on Que!( all kind of suggestions) bad catalytic pull motor replace chain since it aCTS LIKE ITSnot getting enough air i need a good starting point as to whats wrong ... eny help appreciated thank you oh and the compression checks out 148psi on all but one it,s at 127 or so
joe rope is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Mercury > Mountaineer

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:07 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts