Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Buick > Regal
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 12-01-2017, 10:11 AM   #1
jocro
AF Newbie
 
Join Date: Mar 2006
Location: Chesterton, Indiana
Posts: 38
Thanks: 3
Thanked 0 Times in 0 Posts
idiot lights

99 regal...sometimes all the idiot lights are on after starting...cannot use traction control button on consule...go down highway lights go off now have control..just using that button as a reference...thinking something is amiss but do not know where to start. cannot find bad ground but do not even know if that's the problem....any suggestions? JOE
jocro is offline   Reply With Quote
Old 12-01-2017, 09:08 PM   #2
Stealthee
Your worst nightmare
 
Stealthee's Avatar
 
Join Date: Oct 2004
Location: Smithfield, Pennsylvania
Posts: 5,310
Thanks: 4
Thanked 121 Times in 118 Posts
Re: idiot lights

Possible ignition switch issue. The W-bodies of that generation are notorious for them.
__________________
Stealthee is online now   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Buick > Regal

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:18 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts