Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Hyundai > S Coupe
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 01-20-2004, 10:15 PM   #1
hostguyfish
AF Newbie
 
Join Date: Jan 2004
Location: Westminster, Colorado
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Question Heater and radio stopped working

The radio and heater stopped working in my 93 Hyundai scoupe after jump starting it. They did not stop working immediately after the jump but not too long after it. I have checked all fuses and fusable links both in engine compartment and passenger compartment fuse boxes to no avail.

Could it be a relay?

I know that the blower relay clicks when you turn the heater on and off, don't know if it's supposed to or not.

Can anyone help????

Thanks in advance,

MF
hostguyfish is offline   Reply With Quote
Old 01-22-2004, 10:07 PM   #2
tibby01
AF Enthusiast
 
Join Date: Oct 2003
Posts: 1,206
Thanks: 0
Thanked 0 Times in 0 Posts
you said the heater doesnt work. is the air just not hot, or is there no air at all. i would check relays though. take one from something you know is working, and stick it in other spots and see if it fixes it.
tibby01 is offline   Reply With Quote
 
Similar Threads
Thread Thread Starter Forum Replies Last Post
1999 528i Radio Stopped Working shibahill 5 Series 0 07-09-2010 02:51 PM
my windows , fan , and radio stop working ! abeltwo Camaro Discussions 18 05-27-2005 08:45 PM
2002 dodge ram 1500, key fobs and radio stopped working at the same time dow4 Ram Pickup | Ram SRT10 2 12-30-2004 11:20 AM
radio stopped working in my supra turbo GreekPower Maintenance 3 10-30-2004 01:28 PM
Heater and radio stopped working hostguyfish '92-'95 Civic | EL | Civic Hybrid | Civic GX NGV 1 01-20-2004 09:44 PM

Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Hyundai > S Coupe

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:22 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts