Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Engineering/Technical
Engineering/Technical Ask technical questions about cars. Do you know how a car engine works?
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 03-30-2015, 01:05 PM   #1
blazerowner94
AF Newbie
 
Join Date: Mar 2015
Location: South Lyon, Michigan
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
98 Blazer Misfire

My 98 blazer with the 4.3L misfires bad when it is accelerating around 2k rpm and up (especially uphill). It happens mostly in first gear when itís getting close to shifting. It misfires in cylinder 4 and 5(though it misfires much more in 4). Sometimes it drives so bad it wonít shift into overdrive. Replaced spark plugs, cap and wires and O2 sensors. The odd thing sometimes once it warms up I will turn it off and when I turn it on it runs perfect. If itís running bad it doesn't matter if itís fully warmed up or not it runs bad but once I turn it off then turn it back on it runs good sometimes. Also the amount of misfires seems to be getting worse as time goes on.

When its running bad the engine will vibrate the car slightly (but definitely noticeable) at idle, but when running good the car doesn't shake/vibrate at all.

I've read many forums about people with misfire problems in their blazes but nothing about it running better after turning it off then back on. Also everyone seemed to be saying something different and no one had definite answers.

Replacing the injectors next but would that have anything to do with running good after being turned off?

Any ideas what it could be?

Also engine is relatively new, only around 50k on it.

THANKS IN ADVANCE!!!
blazerowner94 is offline   Reply With Quote
Old 03-31-2015, 07:58 PM   #2
NHRA
AF Regular
 
NHRA's Avatar
 
Join Date: May 2005
Location: ocala, Florida
Posts: 149
Thanks: 8
Thanked 9 Times in 9 Posts
Re: 98 Blazer Misfire

try cleaning the egr valve<<<<<<<<<<
NHRA is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks

Tags
blazer, car, chevy, misfire, problems
Go Back   Automotive Forums .com Car Chat > Engineering/Technical

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:36 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts