Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Chrysler > PT Cruiser | PT Cruiser Convertible
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 06-26-2016, 06:27 PM   #1
JBone12
AF Newbie
 
Join Date: Jun 2016
Location: Washington, Missouri
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
2005 PT Cruiser new fan motor not working

New here. 2005 PT Cruiser Touring Edition 2.4 with 69,000 miles. Temp gauge been reading hot when driving on highway or using AC for 20 mins. but not leaking coolant or bubbling over. Just replaced fan motor a month ago with new thermostat & flush, 3rd. time in 6 years. Been in hospital with my mom after having 4th bypass in 3 months, 2 in the last week, so when she started coming around I made the hour drive to try to fix car so I'd have AC when time to bring her home. Stopped & tested at O'Reilly's & got ECT code, $20 & put it in disconnected battery to reset check engine light drove around 30 mins AC was like new again then temp gauge started going up & engine light came on again. back to O'Reilly's tested again & got cylinder 4 misfire, plugs & wires only cpl years old. disconnected battery to reset again this time fan wouldn't kick on at all. back to get tested & got code p0481 cooling fan 2 control circuit malfunction, O'Reilly's said disconnect battery for hr & try again, did that & still no fan. tested again & got code p1684 & cylinder 4 misfire, no p0481. O'Reilly guy said PCM memory was erased & to drive it around till it reset itself. Never had it do this before. Been taking short trips around town so not to overheat it & still no fan! Swapped fan relay with horn relay & good there, checked & cleaned fan switch connector, checked fuses, don't smell any wire burning from PCM or anywhere else, no frayed or melted wires. also replaced oil pressure sensor when I replaced fan motor. Any advice would be greatly appreciated as I need this fixed asap &! as cheap as possible
JBone12 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Chrysler > PT Cruiser | PT Cruiser Convertible

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:32 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts