Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Ford > Explorer | Explorer Sport Trac
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 02-12-2019, 01:55 PM   #1
ford2688
AF Newbie
 
Join Date: Sep 2003
Location: Brooklyn, New York
Posts: 20
Thanks: 1
Thanked 0 Times in 0 Posts
Question Check Engine Light but No Codes

Hi,
Check Engine Light came on. 2009 Ford Explorer 4.0 xlt
Code reader turns up NO Codes, it just cycles through showing dashes (----) but no letter or numbers and will not reset.
I also notice that the Average MPG seems to be stuck around 16.5 mpg no matter the driving condition. I know the mpg would change while driving, but this rarely moves.
Any ideas???
Thanks,
Angelo
__________________
2009 Explorer - Edie Bauer
4.0
Thanks, Angelo
ford2688 is offline   Reply With Quote
Old 02-12-2019, 05:02 PM   #2
65comet
AF Enthusiast
 
65comet's Avatar
 
Join Date: Aug 2004
Location: Porter, Indiana
Posts: 833
Thanks: 7
Thanked 69 Times in 67 Posts
Re: Check Engine Light but No Codes

Sometimes a low voltage condition will cause all kinds of extra or phantom codes. Take it to an auto parts store and see if their code reader comes up with anything. If not, then ask them to check the voltage of the battery and the alternator.
65comet is offline   Reply With Quote
The Following User Says Thank You to 65comet For This Useful Post:
ford2688 (02-12-2019)
Old 02-12-2019, 06:34 PM   #3
ford2688
AF Newbie
Thread starter
 
Join Date: Sep 2003
Location: Brooklyn, New York
Posts: 20
Thanks: 1
Thanked 0 Times in 0 Posts
Re: Check Engine Light but No Codes

Quote:
Originally Posted by 65comet View Post
Sometimes a low voltage condition will cause all kinds of extra or phantom codes. Take it to an auto parts store and see if their code reader comes up with anything. If not, then ask them to check the voltage of the battery and the alternator.
If the weather is a little better tomorrow I'll do that.
Thanks,
Angelo
__________________
2009 Explorer - Edie Bauer
4.0
Thanks, Angelo
ford2688 is offline   Reply With Quote
Old 02-13-2019, 01:17 PM   #4
shorod
SHO Off
 
shorod's Avatar
 
Join Date: Jun 2004
Location: Cedar Rapids, Iowa
Posts: 10,620
Thanks: 65
Thanked 278 Times in 271 Posts
Re: Check Engine Light but No Codes

Quote:
Originally Posted by ford2688 View Post
I also notice that the Average MPG seems to be stuck around 16.5 mpg no matter the driving condition. I know the mpg would change while driving, but this rarely moves.

How long has it been since the Average MPG was reset? The display does exactly what it says, it averages over the MPG from the last time it was reset. If it hasn't been reset for hundreds or thousands of miles, even large changes for a short duration will have very little impact on the overall average.


As for only dashes being shown when checking for diagnostic codes, are you referring to dashes on the diagnostic tool's display or on the display in the Explorer's instrument cluster? Have you ever successfully pulled diagnostic codes from this Explorer using the same diagnostic tool?


-Rod
shorod is offline   Reply With Quote
Old 02-13-2019, 03:42 PM   #5
ford2688
AF Newbie
Thread starter
 
Join Date: Sep 2003
Location: Brooklyn, New York
Posts: 20
Thanks: 1
Thanked 0 Times in 0 Posts
Re: Check Engine Light but No Codes

Quote:
Originally Posted by shorod View Post
How long has it been since the Average MPG was reset? The display does exactly what it says, it averages over the MPG from the last time it was reset. If it hasn't been reset for hundreds or thousands of miles, even large changes for a short duration will have very little impact on the overall average.


As for only dashes being shown when checking for diagnostic codes, are you referring to dashes on the diagnostic tool's display or on the display in the Explorer's instrument cluster? Have you ever successfully pulled diagnostic codes from this Explorer using the same diagnostic tool?


-Rod
I never used this reader on this truck. The dashes were in the code reader.
I'll be back home tomorrow and look at it. Maybe disconnect the battery to reset?
Angelo
__________________
2009 Explorer - Edie Bauer
4.0
Thanks, Angelo
ford2688 is offline   Reply With Quote
Old 02-14-2019, 01:31 PM   #6
ford2688
AF Newbie
Thread starter
 
Join Date: Sep 2003
Location: Brooklyn, New York
Posts: 20
Thanks: 1
Thanked 0 Times in 0 Posts
Re: Check Engine Light but No Codes

Today I just went ahead and disconnected the negative battery terminal for about an hour.
Connected and started and there is NO CHECK ENG. LIGHT.
If it IS going to come back on, how long, or how many miles will that take??
Angelo
__________________
2009 Explorer - Edie Bauer
4.0
Thanks, Angelo
ford2688 is offline   Reply With Quote
Old 02-14-2019, 04:39 PM   #7
65comet
AF Enthusiast
 
65comet's Avatar
 
Join Date: Aug 2004
Location: Porter, Indiana
Posts: 833
Thanks: 7
Thanked 69 Times in 67 Posts
Re: Check Engine Light but No Codes

If the problem doesn't cause an immediate code, usually 60 miles is needed for it to go through all its checks and come up with a firm "things are OK".
65comet is offline   Reply With Quote
Old 02-21-2019, 04:40 PM   #8
ford2688
AF Newbie
Thread starter
 
Join Date: Sep 2003
Location: Brooklyn, New York
Posts: 20
Thanks: 1
Thanked 0 Times in 0 Posts
Re: Check Engine Light but No Codes

Quote:
Originally Posted by 65comet View Post
If the problem doesn't cause an immediate code, usually 60 miles is needed for it to go through all its checks and come up with a firm "things are OK".
Hi,
I disconnected the battery and reset the engine light.
After about 65 mi. the light came back on.
Advance Auto pluged in and came up with a PO128 code.
P0128 Coolant Temperature Below Thermostat Regulating Temperature.

Angelo
__________________
2009 Explorer - Edie Bauer
4.0
Thanks, Angelo
ford2688 is offline   Reply With Quote
Old 02-21-2019, 07:32 PM   #9
shorod
SHO Off
 
shorod's Avatar
 
Join Date: Jun 2004
Location: Cedar Rapids, Iowa
Posts: 10,620
Thanks: 65
Thanked 278 Times in 271 Posts
Re: Check Engine Light but No Codes

If that's the only diagnostic code currently, there's a good chance your thermostat is stuck open and the engine is not getting to the expected operating temperature. Changing your thermostat may fix the issue. If you opt to change the thermostat, you may also want to make sure you can get a thermostat housing in the event you find yours damaged or damage it during the removal process.


-Rod
shorod is offline   Reply With Quote
Old 02-22-2019, 04:43 AM   #10
ford2688
AF Newbie
Thread starter
 
Join Date: Sep 2003
Location: Brooklyn, New York
Posts: 20
Thanks: 1
Thanked 0 Times in 0 Posts
Re: Check Engine Light but No Codes

I did notice that the truck runs cold. The needle would reach just to
the low range on the gage. Could be stuck open.
Angelo
__________________
2009 Explorer - Edie Bauer
4.0
Thanks, Angelo
ford2688 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Ford > Explorer | Explorer Sport Trac

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:56 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts