Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Chevrolet > Avalanche | C&K | Silverado | Suburban | Tahoe > Silverado
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 12-03-2018, 01:41 PM   #1
kevin23
AF Newbie
 
Join Date: Sep 2006
Location: cedar bluff, Alabama
Posts: 53
Thanks: 3
Thanked 0 Times in 0 Posts
Won't start with out start fluid

2000 Silverado, V 6, 90,000 miles fuel gauge goes from full to empty at random, won't start without a blast of start fluid. SES light on.
I suspect fuel pump. Will this cause SES light to come on?

With start fluid , starts right up, runs smooth at idle, then runs rough at 1000 rpms.

Thanks for any help.
kevin23 is offline   Reply With Quote
Old 12-03-2018, 05:17 PM   #2
maxwedge
A990 racer
 
Join Date: Mar 2002
Location: Chestertown, New York
Posts: 16,518
Thanks: 13
Thanked 315 Times in 309 Posts
Re: Won't start with out start fluid

How about getting the code read, then we can suggest some meaningful advice.
__________________
maxwedge is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Chevrolet > Avalanche | C&K | Silverado | Suburban | Tahoe > Silverado

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:19 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts