Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Lincoln > LS | MKZ
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 08-25-2018, 09:38 PM   #1
mprtech
AF Regular
 
Join Date: Sep 2004
Location: Milwaukee, Wisconsin
Posts: 111
Thanks: 0
Thanked 0 Times in 0 Posts
08 3.5 Leaking VVT actuator seal, repeat failure

Hey guys. My wife has a 08 mkz with a 3.5. I replaced the phasers and actuators for a misfire fault. That problem is taken care of. I replaced valve cover seals, plug tube seals and VVT seals at that time. Two weeks later I have a puddle of fresh oil on the floor. I traced the leak to the rear VVT seal, it was basically shredded. After a wtf session in replaced the seal. Two weeks later it did the same thing. Iím a mopar tech, but a car is a car. Anybody seen this happen before? Thanks much
mprtech is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Lincoln > LS | MKZ

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:40 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts