Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Ford > ZX2
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 01-26-2009, 01:46 PM   #1
zbo2
AF Newbie
 
Join Date: Dec 2003
Location: Newfield, New Jersey
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to zbo2
01 ZX2 problem...

01 zx2 that has been stalling when comming to a stop. it runs a little ratty in gear when stopped and also has a little hesitation comming off idle. it coded with a cam sensor problem and OBD2 didn't complete self test. i change the cam sensor, cleaned the throttle body and checked all the vacuum lines (fine).
i cleared the codes and they came back...same ones. with the computer hooked up i don't see any problems with any of the running peramitors. when driving down the road the cars runs great....it's just at idle and the off idle response when in gear that sucks. any suggestions?
zbo2 is offline   Reply With Quote
Old 02-07-2009, 09:00 PM   #2
zbo2
AF Newbie
Thread starter
 
Join Date: Dec 2003
Location: Newfield, New Jersey
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to zbo2
Re: 01 ZX2 problem...

does anyone know if the connector plug for the cam sensor on this car is the same as a regular escort? one of the wires is broken right at the end of the connector and i need to try to get one out of a junk yard......also does anyone know the ford part number for the cam sensor.....there is a connector end on eBay but i need the ford part number to see if it's the same...
thanks
Joe
zbo2 is offline   Reply With Quote
Old 02-15-2009, 04:59 PM   #3
v_lestat
AF Newbie
 
Join Date: Feb 2008
Location: Cedar Rapids, Iowa
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 01 ZX2 problem...

why would you risk buying a bad sensor from a junk yard, thats just foolish, just go buy a new sensor.
of course i say that not knowing how much a new cam sensor is.
but buying one from a JY is just silly.
v_lestat is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Ford > ZX2

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:06 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts