Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Ford > Fiesta
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 12-01-2017, 02:51 AM   #1
lukaskasc@gmail.co
AF Newbie
 
Join Date: Dec 2017
Location: Kaunas
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Ford fiesta mk4 1.25 55kw problems

Hey i have a Ford Fiesta mk4 1.25 55kw and i need your help. Half of my electronics stopped working and i happend after i rolled down a hill and started up the car. Things that stoped working: tail lights, marker lamps at front, back foglight, speedometer light, and radio light on buttons but not on the screen.

And yes i checked the fuses
lukaskasc@gmail.co is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Ford > Fiesta

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:43 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts