Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Pontiac > Solstice
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 09-14-2015, 02:31 PM   #1
roycism2008
AF Newbie
 
Join Date: May 2008
Location: ball, Louisiana
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
no start-no run problem

brain hurts now. been working on this problem for a week. 2008 solstice convertible 2.4 auto. it started out as a no start-no run problem. scan all control modules. codes were u2105, u2129, u2107, u0140, u0155,
and u0100. all were about lost communication to bcm-ecm-tcm modules. check all wire harnesses, did the ohms and voltages check out. found the ecm not working with others. replaced new ecm. clear codes and
start-run engine. scan running engine for codes. p0315 ckp system variation not learning and p0602 ecm not programmed came up. went to stream data to check crank-cam counts. crank count was showing working. the intake cam count was working. the exhaust cam count not working.swap out both cam sensors and the same result. exhaust not working. check volts 5v to the correct pins. now here is where im stuck. if i clear codes in ecm i can start-run engine. turn off and start-run engine. did it for 5 cycles. if i start-run engine then turn off engine and count to 30secs. no start-run engine. but clear codes in ecm then start-run engine. ok now what am i missing here. i have a genesys 5 scanner so i can get into the computers good. please anyone can help me. thanks and sorry for the long post.
roycism2008 is offline   Reply With Quote
Old 09-14-2015, 03:46 PM   #2
DeltaP
AF Enthusiast
 
Join Date: Oct 2011
Location: Ft Lauderdale, Florida
Posts: 953
Thanks: 13
Thanked 121 Times in 120 Posts
Re: no start-no run problem

Was the PCM programmed or flashed to the Vin number?
DeltaP is offline   Reply With Quote
Old 09-14-2015, 03:54 PM   #3
Tech II
AF Fanatic
 
Join Date: Jul 2011
Location: Worcester, Massachusetts
Posts: 4,952
Thanks: 54
Thanked 611 Times in 603 Posts
Re: no start-no run problem

Also, when a PCM is changed, you have to perform the crank variation relearn procedure......need a GM scan tool to do that...
Tech II is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Pontiac > Solstice

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:47 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts