Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Ford > Mustang > Mustang Problem Diagnosis
Mustang Problem Diagnosis Got a problem you can't fix? Post here and one of our members will answer as soon as possible.
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 01-20-2018, 10:23 PM   #1
ForeverDrivin
AF Newbie
 
Join Date: Jan 2018
Location: Bradenton
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
1998 Mustang V6 Loses power randomly and sometimes stalls. Fuel related?

So my used 1998 V6 Mustang has a problem. It runs on normal roads just fine, but recently it started acting up on the highway. Me and my father were driving normally on the highway and it suddenly lost all it's power and started slowly decelerating. The power was just gone. It did this three times on the highway, first two times having to come to a complete stop and on the third time we luckily managed to pull off into a parking lot. We decided to take a back road but it started crapping out then too. And the fifth time (second time dying on the 40 mph back way) it wouldn't start. Tow it home, and it starts no problem. We take it up and down a short road and it starts to barely sputter and loses power for a couple seconds, almost stalling multiple times, but keeps running. Today I replaced the fuel filter. Didn't get to test on a fast road but did feel it still lose power for a couple seconds when driving or revving in between gears, and still stalled once. Also smells of fuel a little
ForeverDrivin is offline   Reply With Quote
Old 07-28-2018, 09:32 PM   #2
quickcurrent
AF Regular
 
Join Date: Feb 2008
Location: Toronto
Posts: 116
Thanks: 4
Thanked 0 Times in 0 Posts
Re: 1998 Mustang V6 Loses power randomly and sometimes stalls. Fuel related?

The fuel filter would have been my guess. :-(
quickcurrent is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks

Tags
fuel, powerloss, sputter, stall
Go Back   Automotive Forums .com Car Chat > Ford > Mustang > Mustang Problem Diagnosis

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:45 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts