Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Ford > F Series
F Series Forum covers questions and discussions regarding Ford F-150, Ford F-250, Ford F-350, Ford F-450, Ford F-550, Ford F-650, and Ford F-750.
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 06-02-2011, 07:05 PM   #1
turfmanager
AF Newbie
 
Join Date: Jun 2011
Location: Rogers, Arkansas
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Throttle Position Sensor????

2003 Ford F150 V-6, 4.2 liter, 275,000 miles.



Would a bad or out of whack throttle position sensor cause my truck to run rough and pop and sputter when accelerating from a dead stop while driving around town? I found a vaccuum leak today and repaired that, but it didnt fix my problem. Should I disconnect the battery for a while and hook it back up? Will that reset it? This only really started when the weathr warmed up this week. My truck idles just fine and does not jump run rough at all. I cleaned my mass air flow sensors with electronics cleaner, they were dirty. Any suggestions?
turfmanager is offline   Reply With Quote
Old 06-05-2011, 01:40 PM   #2
jyount
AF Regular
 
Join Date: Feb 2004
Location: Farmington, Missouri
Posts: 481
Thanks: 0
Thanked 14 Times in 14 Posts
Re: Throttle Position Sensor????

Quote:
Originally Posted by turfmanager View Post
2003 Ford F150 V-6, 4.2 liter, 275,000 miles.



Would a bad or out of whack throttle position sensor cause my truck to run rough and pop and sputter when accelerating from a dead stop while driving around town? I found a vaccuum leak today and repaired that, but it didnt fix my problem. Should I disconnect the battery for a while and hook it back up? Will that reset it? This only really started when the weathr warmed up this week. My truck idles just fine and does not jump run rough at all. I cleaned my mass air flow sensors with electronics cleaner, they were dirty. Any suggestions?
To answer your question, yes, but so will many other things. The first conclusion people usually jump to is something electrical. 9 times out 10 its not... Diagnose it instead of tossing parts at it. Any codes?
__________________
10 hours away from John Deere master certified
also master certified ASE tech. Exp. in both.
Went to school for cars, wound up staying with Deere dealer for a while, so schooling there too. Also couple years exp in GM and some GM training
Gave up wrenching for "Greener Pastures"

Current job: RN

2010 Silverado Z71 5.3L 65xxx

Wife's
2007 Suburban 1500 LTZ 5.3L 102xxx
jyount is offline   Reply With Quote
 
Similar Threads
Thread Thread Starter Forum Replies Last Post
Throttle Position Sensor/Throttle Body ktl4974 Nissan Cefiro | Nissan Maxima | Infiniti I30 | Infiniti I35 8 06-30-2010 12:39 PM
Pontiac GA Cam position sensor LOCATION ? cigars99 Grand AM 6 07-11-2009 11:30 AM
Throttle Body and Throttle Position Sensor Jmrec100 Legend | RL 2 12-17-2005 02:59 AM
Location of crankshaft sensor and throttle position sensor rudy49 Grand Cherokee | Grand Cherokee SRT8 2 01-26-2005 02:56 PM
Throttle Position Sensor/Throttle Switch Adjustment westsidex Metro 3 05-24-2004 07:17 PM

Reply

POST REPLY TO THIS THREAD


Bookmarks

Tags
acceleration, position, rough, sensor, throttle
Go Back   Automotive Forums .com Car Chat > Ford > F Series

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:29 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts