Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Chevrolet > Avalanche | C&K | Silverado | Suburban | Tahoe > Silverado
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 02-22-2007, 06:43 PM   #1
jstudent33
AF Newbie
 
Join Date: Feb 2007
Location: Mogadore, Ohio
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Question 99 Silverado

I have a 99 Silverado 4.3L 5-speed transmission. Recently my check engine light has been coming on and I have noticed a flutter while I'm driving down the road. It only does it when I am at a steady speed and sometimes when I rev it up. When I step on it or get completely off the throttle it runs fine. I have changed the plugs and wire and nothing happened. Any help would be greatly appretiated.
jstudent33 is offline   Reply With Quote
Old 02-22-2007, 08:02 PM   #2
TexasF355F1
AF Fanatic
 
TexasF355F1's Avatar
 
Join Date: Jan 2003
Location: Huntsville/Houston, Texas
Posts: 7,776
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to TexasF355F1
Re: 99 Silverado

Sounds like the fuel pump and fuel pressure regulator issue.
__________________
*Under Construction - New sig to debut*
TexasF355F1 is offline   Reply With Quote
Old 02-22-2007, 08:09 PM   #3
Sonny01
AF Enthusiast
 
Sonny01's Avatar
 
Join Date: Jan 2004
Location: Hilliard, Ohio
Posts: 651
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 99 Silverado

Since you get a light take it to a parts store that offers free use of a scanner to get the code.
Sonny01 is offline   Reply With Quote
Old 02-22-2007, 08:12 PM   #4
jstudent33
AF Newbie
Thread starter
 
Join Date: Feb 2007
Location: Mogadore, Ohio
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 99 Silverado

I had a friend hook it up and it said random cylinder misfire
jstudent33 is offline   Reply With Quote
Old 02-23-2007, 07:56 AM   #5
geebeer
AF Newbie
 
Join Date: Feb 2007
Location: Buna, Texas
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 99 Silverado

I have a 99 silverado with the same motor as you do... with the same issue you are having too. I have automatic tranismission but it feels like a random cylinder misfire when I gas on it while driving... or climb an overpass etc... Otherwise it runs steady just like yours. I've put new plugs, wires, cap & rotor with no solution. I've checked my air filter which is in good shape... so my next try might be my fuel filter. I put a new one on about 6 months ago but maybe I have some junk? Just a thought... Anyone else have a suggestion?
geebeer is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Chevrolet > Avalanche | C&K | Silverado | Suburban | Tahoe > Silverado

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:29 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts