Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Dodge > Ram Pickup | Ram SRT10
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 11-24-2020, 08:46 PM   #1
Klotus420
AF Newbie
 
Join Date: Nov 2020
Location: Atlanta, Georgia
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
02 Dodge Ram 1500 Crank No Start Help

My Ram shut off one day on the highway and has been a crank no start since.
Symptoms:
When key is in the on position everything works besides the Voltage and Gas gauge.

Scan tool will not communicate

Fuel Pump wont prime

I get C code AA (pcm message not received)

Sometimes for NO reason at all I'll go out turn the key, the Voltage and Gas gauge work the fuel pump primes and the truck starts right up, I'll get communication on my scanner and I get absolutely no codes Other than the C code AA
When that happens I'll drive down the street and it seems fine, other than hesitation shifting gears.

I Originally thought it was the fuel pump so I replaced it, no change. Then I replaced the Crankshaft position sensor... still no change. I checked all fuses and relays everything was fine. But one day I decided to charge the battery up while installed and I also took out the PCM to visually check it and the wires as well. Didnt see anything wrong reinstalled it battery got fully charged, I went and flipped the key and everything worked and truck started right up. That was the first time it started and ever since then it's been random works one day doesn't the next, so I got a new battery, started every time for about a week and then went back to random.

What could this be? I'm at a loss. I thought maybe it was the PCM.. but wouldnt make since for it to run fine sometimes and others not at all
Klotus420 is offline   Reply With Quote
Old 11-25-2020, 09:40 AM   #2
aleekat
AF Enthusiast
 
Join Date: Dec 2001
Location: clarksville, Tennessee
Posts: 1,486
Thanks: 12
Thanked 159 Times in 156 Posts
Re: 02 Dodge Ram 1500 Crank No Start Help

Since worked with new battery for a while. I would be checking charging system.
__________________
Post back, that's what makes Forums Work.
aleekat is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Dodge > Ram Pickup | Ram SRT10

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:44 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts