Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Oldsmobile > Cutlass Series
Cutlass Series Includes Cutlass Ciera, Cutlass Cruiser, Cutlass Calais, Cutlass Supreme, Custom Cruiser, as well as the GM N-Body subforums.
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 12-07-2008, 04:28 PM   #1
randini667
AF Newbie
 
randini667's Avatar
 
Join Date: Jan 2007
Location: Grand Rapids, Michigan
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Fuel pump runs 5-9 secs after I turn off car.

Hello,

I have a 1991 Oldsmobile Cutlass Supreme.

I wanted to run my situation past you all and see what you think. My fuel pump consistently runs somewhere between 5-9 seconds after I turn the car off. Is this normal, and if not, do you have any advice? (Just a note, the fuel filter is new.) Thanks!

-Randy

Last edited by randini667; 12-07-2008 at 04:34 PM. Reason: Typo
randini667 is offline   Reply With Quote
Old 12-07-2008, 05:08 PM   #2
brcidd
AF Enthusiast
 
brcidd's Avatar
 
Join Date: Jul 2005
Location: troy, Ohio
Posts: 2,274
Thanks: 2
Thanked 168 Times in 166 Posts
Re: Fuel pump runs 5-9 secs after I turn off car.

Yes it is normal- but usually only 3 or 4 seconds- it is the residual oil pressure that has to disapate to below 4 psi to disable the oiil pressure switch that is in parallel to the fuel pump relay. Your oil may be thicker than most, or some other reason.
__________________
Automotive A/C Engineer with:
'99 IH 4700 Toy Hauler
(2) '95 GEO Prizms both maroon
'99 GMC Yukon
'95 Chev 3500, 454 Dually Crew Cab- 145k miles-
Wife's Camel trailer puller.
'94 Astro- 370k miles
'94 Firebird Formula- 5.7L 180k miles- gone-
'92 Chevy Lumina Van 3.8L 264k
'86 GMC S-15 - 2.8L 154k
'87 Buick Park Ave . 187k
'86 Buick Park Ave 3.8L 199k miles- gone
'77 Chevy Vega- 2.5L 175k miles gone but not forgotten
'68 Camaro 396 4 spd RS/SS -72k miles-
brcidd is offline   Reply With Quote
Old 12-08-2008, 05:56 PM   #3
severence
AF Newbie
 
Join Date: Dec 2008
Location: Staten Island, New Jersey
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Fuel pump runs 5-9 secs after I turn off car.

Quote:
Originally Posted by randini667
Hello,

I have a 1991 Oldsmobile Cutlass Supreme.

I wanted to run my situation past you all and see what you think. My fuel pump consistently runs somewhere between 5-9 seconds after I turn the car off. Is this normal, and if not, do you have any advice? (Just a note, the fuel filter is new.) Thanks!

-Randy
what in the world possessed you to buy a cutlass supereme?
severence is offline   Reply With Quote
Old 12-29-2008, 09:21 PM   #4
randini667
AF Newbie
Thread starter
 
randini667's Avatar
 
Join Date: Jan 2007
Location: Grand Rapids, Michigan
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Fuel pump runs 5-9 secs after I turn off car.

I don't follow, cutlass supreme a piece of crap?


I noticed that the fuel pump does run for a couple of seconds, the sound that I'm noticing is the hydraulic brake pump motor. Thanks for the info.

-Randy
randini667 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Oldsmobile > Cutlass Series

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:06 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts