Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Pontiac > Grand AM
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 11-29-2007, 12:42 PM   #1
gsimburg
AF Newbie
 
Join Date: Nov 2007
Location: Collinsville, Illinois
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Horn problems

2001 Grand AM SE, horn will not work on the steering column pad, and will not work when I push locks on the key fob. Fuse is good, relay is good, and the horn works when I jumper the power at the relay. Any suggestions??
gsimburg is offline   Reply With Quote
Old 11-29-2007, 04:17 PM   #2
J-Ri
AF Enthusiast
 
J-Ri's Avatar
 
Join Date: Dec 2004
Location: Shellsburg, Iowa
Posts: 3,218
Thanks: 8
Thanked 1 Time in 1 Post
Re: Horn problems

make sure you have power and ground to the controlling side of the relay (pins 85&86) when the horn button is pushed.
__________________
'04 Cavalier coupe M/T 2.2 Ecotec
Supercharged 14 PSI boost, charge air cooler, 42# injectors
Tuned with HP Tuners
Poly engine/trans/control arm bushings
Self built and self programmed progressive methanol injection system
J-Ri is offline   Reply With Quote
Old 11-29-2007, 06:02 PM   #3
xeroinfinity
out saving the world
 
xeroinfinity's Avatar
 
Join Date: Jul 2005
Location: Yourtown, Indiana
Posts: 10,698
Thanks: 8
Thanked 18 Times in 18 Posts
Re: Horn problems

Welcome to AF gsimburg.

Has the steering wheel or air bag been off recently ?
__________________
1999 Grand Am SS 3.4 OHV
xeroinfinity is offline   Reply With Quote
Old 11-16-2008, 07:37 AM   #4
my65vette
AF Newbie
 
Join Date: Feb 2005
Location: Highlands Ranch, Colorado
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Horn problems

We took our airbag off to replace the multifunction switch. The horn worked fine before. When we put the airbag back on, the horn does not work.
my65vette is offline   Reply With Quote
Old 11-16-2008, 01:28 PM   #5
J-Ri
AF Enthusiast
 
J-Ri's Avatar
 
Join Date: Dec 2004
Location: Shellsburg, Iowa
Posts: 3,218
Thanks: 8
Thanked 1 Time in 1 Post
Re: Horn problems

Pull the air bag back off and make sure the horn wires are connected.
__________________
'04 Cavalier coupe M/T 2.2 Ecotec
Supercharged 14 PSI boost, charge air cooler, 42# injectors
Tuned with HP Tuners
Poly engine/trans/control arm bushings
Self built and self programmed progressive methanol injection system
J-Ri is offline   Reply With Quote
Old 11-16-2008, 01:34 PM   #6
xeroinfinity
out saving the world
 
xeroinfinity's Avatar
 
Join Date: Jul 2005
Location: Yourtown, Indiana
Posts: 10,698
Thanks: 8
Thanked 18 Times in 18 Posts
Re: Horn problems

Sounds like you damaged or knocked loose the clock spring under the steering wheel.

Make sure the spring under the air bag is touching the plate under the steering wheel and making contact with the above contact(s).
It is possible the compontent could be damaged and need replaced which requires you to remove the steering wheel, or live without a horn.

Hope that helps.
__________________
1999 Grand Am SS 3.4 OHV
xeroinfinity is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Pontiac > Grand AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:06 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts