Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Oldsmobile > Alero
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 09-21-2008, 09:44 PM   #1
rjs0421
AF Newbie
 
Join Date: May 2008
Location: Swartz Creek, Michigan
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Alero Drive Shaft Help

Anyone have any drive shafts, mainly U joints going bad? I have 190,000 miles on mine and the tracking shuts off and different times and under different occassions. I have new rotors, hubs and pads so I know it's not the bearings. I do have a slight rumble I feel coming from the left side when braking real hard and when turning at slower speeds. On the highway I feel nothing but have a very faint knuckling sound. I am guessing a U joint is failing. A new shaft is less than $100 and I have replaced them on another car before.
rjs0421 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Oldsmobile > Alero

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:59 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts