Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > GMC > Savana
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 09-24-2009, 07:21 PM   #1
sloechli
AF Newbie
 
Join Date: Jan 2004
Location: Saline, Michigan
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Blower motor sticks on high speed

I have a 2003 2500 6.0 liter Savana, the blower motor twice now has switched to high speed even though the control is on low speed. The first time it happened my wife turned the speed switch from high to low about 5 times, then it went back to low speed and seemed to function fine.

Today it did the same thing, but would not drop out of high speed. It even kept going with engine off and key out. after about 15 min and multiple on off it and fan speed adjustment, it finally worked.

Does this sound like a resistor/relay?

Steve
sloechli is offline   Reply With Quote
Old 09-24-2009, 07:34 PM   #2
cspring
AF Newbie
 
Join Date: Sep 2009
Location: torrington, Connecticut
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Blower motor sticks on high speed

could be a stuck relay but it's strange that it stays on even with the key off.
cspring is offline   Reply With Quote
Old 05-25-2010, 12:15 PM   #3
sloechli
AF Newbie
Thread starter
 
Join Date: Jan 2004
Location: Saline, Michigan
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Blower motor sticks on high speed

Fan stuck on again,
Anyone have any similar experience or help?
sloechli is offline   Reply With Quote
Old 08-23-2010, 08:21 AM   #4
mad max
AF Newbie
 
Join Date: Nov 2003
Location: Hull, Massachusetts
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Blower motor sticks on high speed

Had similar problems with my Chevy van and it was that shitty resister. Had similar problem with many ford vans and it was always the shitty switch.
mad max is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > GMC > Savana

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:21 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts