Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Engineering/Technical
Engineering/Technical Ask technical questions about cars. Do you know how a car engine works?
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 03-13-2009, 09:56 AM   #1
racefan978
AF Newbie
 
Join Date: Mar 2009
Location: walled lake, Michigan
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
94 camaro z28 lt1 cooling problem

My car is not cooling properly. My over flow jug stays full but my radiator does not it is not taking the antifreeze from the jug.I have replaced water pump and thermostat and i still have the problem.Can anyone help me please.
racefan978 is offline   Reply With Quote
Old 03-13-2009, 08:51 PM   #2
curtis73
Professional Ninja Killer
 
curtis73's Avatar
 
Join Date: Nov 2002
Location: Penn Hills, Pennsylvania
Posts: 3,558
Thanks: 0
Thanked 9 Times in 9 Posts
Re: 94 camaro z28 lt1 cooling problem

How can you tell the radiator isn't full?
__________________
Dragging people kicking and screaming into the enlightenment.
curtis73 is offline   Reply With Quote
Old 03-14-2009, 09:00 AM   #3
racefan978
AF Newbie
Thread starter
 
Join Date: Mar 2009
Location: walled lake, Michigan
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 94 camaro z28 lt1 cooling problem

When i let it cool down i take the cap off.The antifreeze level is low.I was messing with it and found that when i mash the gas antifreeze blows out the top of the fill jug(catch can,overflow.

Last edited by racefan978; 03-14-2009 at 10:48 AM.
racefan978 is offline   Reply With Quote
Old 03-14-2009, 12:31 PM   #4
curtis73
Professional Ninja Killer
 
curtis73's Avatar
 
Join Date: Nov 2002
Location: Penn Hills, Pennsylvania
Posts: 3,558
Thanks: 0
Thanked 9 Times in 9 Posts
Re: 94 camaro z28 lt1 cooling problem

I didn't think that 94s had a radiator cap... I thought they just had the surge tank cap.

The only thing I can think of is a clogged heater core or clogged heater hoses. If they follow the same cooling path as I think they do, the water goes to the heater core, then back to the radiator via the surge tank.
__________________
Dragging people kicking and screaming into the enlightenment.
curtis73 is offline   Reply With Quote
Old 03-14-2009, 01:48 PM   #5
racefan978
AF Newbie
Thread starter
 
Join Date: Mar 2009
Location: walled lake, Michigan
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 94 camaro z28 lt1 cooling problem

I was thinking along that line but i wanted some advice i don't know everything.I had a friend tell me it might be the radiator cap.what do you think.Thank you for the advice I appreciate it.I will let you know what happens or i find out.
racefan978 is offline   Reply With Quote
Old 05-29-2009, 08:37 PM   #6
Mavrick14
AF Newbie
 
Join Date: May 2009
Location: Ontario
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 94 camaro z28 lt1 cooling problem

Replace your rad cap and pressure test the cooling system. The cooling system should build pressure when hot, and when it cools down it should create a vacuum and suck the coolant from the overflow back into the motor. Your cap controls both the pressure relief and the vacuum return.
Mavrick14 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Engineering/Technical

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:51 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts