Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Nissan > Altima
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 01-20-2007, 11:15 AM   #1
crazyy_e
AF Newbie
 
Join Date: Oct 2006
Location: Sudbury
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation 2006 Altima no heat when idling

Alright. So i'm having this issue with my altima, and it's been at the dealership for it's third time and they have to clue what's going on. Here's what's happening. First, let me say it's like 20 below where I live in Canada. When I start the car in the morning to let it warm up, the heat works great, I get in after like 5 min and heat is starting to come out. Now lets say I drive about a 1 km to a coffee shop, and leave my car on while I run inside. Looking at my temp gauge, it's at normal operating temperature and the heat is coming out at full force. After a few minutes, I get back in my car, and it's blowing freezing air, and it take a few minutes of driving to get it back hot. The temp gauge stays at the same place the whole time, being the middle of the gauge. First, Nissan said it must have had an air pocket, so they checked that and said yes that was the problem. It did it again after a day. So I brought it back and now they said the coolant was testing much to low for the thermostat the car has, so they drained some and put the correct amount to make it 50/50. Now its doing it again and they dont know what it is. Can anyone help me please. Thanks!!

Last edited by crazyy_e; 01-21-2007 at 01:06 PM.
crazyy_e is offline   Reply With Quote
Old 01-20-2007, 08:03 PM   #2
jimmy-Hands-on
AF Newbie
 
Join Date: Jan 2007
Location: Burlington, North Carolina
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Cool Re: 2006 Altima no heat when idling

Quote:
Originally Posted by crazyy_e
Alright. So i'm having this issue with my altima, and it's been at the dealership for it's third time and they have to clue what's going on. Here's what's happening. First, let me say it's like 20 below where I live in Canada. When I start the car in the morning to let it warm up, the heat works great, I get in after like 5 min and heat is starting to come out. Now lets say I drive about a 1 km to Tim Hortons, and leave my car on while I run inside. Looking at my temp gauge, it's at normal operating temperature and the heat is coming out at full force. After a few minutes, I get back in my car, and it's blowing freezing air, and it take a few minutes of driving to get it back hot. The temp gauge stays at the same place the whole time, being the middle of the gauge. First, Nissan said it must have had an air pocket, so they checked that and said yes that was the problem. It did it again after a day. So I brought it back and now they said the coolant was testing much to low for the thermostat the car has, so they drained some and put the correct amount to make it 50/50. Now its doing it again and they dont know what it is. Can anyone help me please. Thanks!!
Hi, I am excited to join this forum. Today is my first day and your case interested me.

I would look into the blower unit.

My guess is the outside cold air gets in due to the switching flaper is at wrong position when that happens. It could be contributed from some positioner or spring poped or broke.
Would like to know your final solution. Please advise if you get it solved.
Regards
jimmy
jimmy-Hands-on is offline   Reply With Quote
Old 01-21-2007, 12:20 AM   #3
crazyy_e
AF Newbie
Thread starter
 
Join Date: Oct 2006
Location: Sudbury
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2006 Altima no heat when idling

Hi Jimmy. Thanks for the info. I will get them to check into that. Thank god I still have heat when i'm driving though, it's just a pain in the butt when i get back in and it's freezing. I'll let you know what happens once it comes back. Eric
crazyy_e is offline   Reply With Quote
Old 01-21-2007, 11:56 AM   #4
deerefeed
AF Newbie
 
Join Date: Jun 2006
Location: London
Posts: 98
Thanks: 7
Thanked 0 Times in 0 Posts
Re: 2006 Altima no heat when idling

Crazyy e,
I have to wonder what's going through the minds of most Americans reading your post about driving to Tim's and running inside for a minute. Not that it matters to diagnose your problem, but we as Canadians know that Timmies is a Canadian institution, now owned by an American conglomerate. You've got me wanting to go get a coffee now.
deerefeed is offline   Reply With Quote
Old 01-21-2007, 01:07 PM   #5
crazyy_e
AF Newbie
Thread starter
 
Join Date: Oct 2006
Location: Sudbury
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2006 Altima no heat when idling

Haha, Yes you're right, I edited me post to say coffee shop. Hope it clarifies the mind of some people.
crazyy_e is offline   Reply With Quote
Old 01-24-2007, 11:03 PM   #6
Nightshift396
AF Newbie
 
Join Date: Jan 2007
Location: Ottawa
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2006 Altima no heat when idling

My wife has a 2004 Altima with exactly the same problem ... heater works fine as long as the car is in motion, but as soon as you stop at a red light, it starts blowing cold air. Once you start driving again, the heater starts blowing warm air. It never blows hot!

This seems to be a very common problem for Altima's going back to 2000 and 2001 models, yet I have not found a solution. I sure hope someone here can figure this out as the dealers don't seem to have a clue.
Nightshift396 is offline   Reply With Quote
Old 01-26-2007, 11:12 PM   #7
crazyy_e
AF Newbie
Thread starter
 
Join Date: Oct 2006
Location: Sudbury
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2006 Altima no heat when idling

Hey. Thanks for that message. They told me it was the first time they saw it, but that's exactly what it does. And when I say cold air I mean cold air. If they figure something out, i'll let you know, it's gonna go in again on Tuesday, since they have lots of time to look at it then.

Eric
crazyy_e is offline   Reply With Quote
Old 01-27-2007, 08:53 AM   #8
Nightshift396
AF Newbie
 
Join Date: Jan 2007
Location: Ottawa
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2006 Altima no heat when idling

Eric, I'm in your neck of the woods also (Ontario), and I don't know what dealer you are using, but the one we have in London was useless to solve this while the car was in warranty. I no longer have any clout with them as they don't have to repair the car for free. They are quite willing to start replacing heater cores, controls, etc. (at my full expense of course) now as trial and error to fix the problem ... but I suspect based on what others have experienced that I could spend a couple thousand $ and still have cold air coming out of my heater when idling.

Lucky for you, your car is in warranty ... so stick with it and FORCE them to solve the problem. It is THEIR problem ... not yours as you bought the car (just as I did) expecting a working heater. Wish you good luck. Bill
Nightshift396 is offline   Reply With Quote
Old 01-30-2007, 09:17 PM   #9
crazyy_e
AF Newbie
Thread starter
 
Join Date: Oct 2006
Location: Sudbury
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2006 Altima no heat when idling

Alright. Everything seems to be fine and dandy now. Just got it back today, and they said it was airlock once again. They promised they got it all out, so as I left the dealership, I drove it for about 15 min to get it at operating temperature, then put it in park in a parking lot for another 15 min. The air stayed warm the whole time. It was only around -15 degrees C today however, so I will see in the morning. Hopefully that's what the problem was. I'll keep you guys posted on the outcome.

Eric
crazyy_e is offline   Reply With Quote
Old 02-03-2007, 10:13 PM   #10
FixUrNissan
AF Regular
 
FixUrNissan's Avatar
 
Join Date: Oct 2005
Location: Oakland, New Jersey
Posts: 354
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2006 Altima no heat when idling

I was Going to advise Nissan owners . The coolant system is very sensitive to air. You get an air pocket what so ever in all Nissan's , you can have a few symptoms ,
1 no heat
2 no heat at idle , but heat when moving
3 over heating.

Check coolant systems and have them Bleed out. Nissan recommend lifting the front of the vech , so the radiator cap is at its highest point so Air can be released. If any one has a question about it, feel free to ask me.. GL all
__________________
FixUrNissan is offline   Reply With Quote
Old 02-04-2007, 09:08 PM   #11
crazyy_e
AF Newbie
Thread starter
 
Join Date: Oct 2006
Location: Sudbury
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2006 Altima no heat when idling

Well I spoke to soon. It was -29 degrees celsius this morning (-20 F), started the car for a good 10 min, was warm when I got in, got even hotter as I was driving to the store, let it idle while I ran inside for about 2 minutes, came back in and she's blowing freezing air again!!! Gonna go back to Nissan tomorrow and tell em. Hopefully they can make sure things are done right.

Update!

Well nissan told me today that I can't run the fan on high or set on auto (if it's cold in the car, the fan will go on high automatically). They said that it doesn't get a chance to warm up and just shoots all the cold air inside the car before warming it up. So we need to put it in the middle speeds. I'm not sure about you, but shouldn't it work at all speeds? it is in fact a new car and even my older cars warm up on the highest fan speed no matter what. We'll see how that goes tomorrow morning.

Last edited by crazyy_e; 02-05-2007 at 10:59 AM.
crazyy_e is offline   Reply With Quote
Old 02-06-2007, 12:22 PM   #12
nissandoc
AF Regular
 
nissandoc's Avatar
 
Join Date: Jan 2006
Location: Raleigh, North Carolina
Posts: 132
Thanks: 0
Thanked 1 Time in 1 Post
Re: 2006 Altima no heat when idling

had a car in the shop today with the exact same problem. bleeding the air from the system didnt help at all(which is usually the problem). car was not overheating at all, everything normal except no heat at idle, replaced the thermostat and heat working normal now. will have to wait and see if this fix's long term.
nissandoc is offline   Reply With Quote
Old 02-07-2007, 10:50 PM   #13
Sash
AF Newbie
 
Join Date: Feb 2007
Location: Trenton, New Jersey
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2006 Altima no heat when idling

I'm also running around crazzy for over a month to resolve this heat problem. I started with radiator fluid flush, bleed radiator, engine oil flush, and just today I replaced the thermostat. and still doesn't work at all. I already spent over $300. Tomorrow I'm having heater coil under the dashboard replace, its going to cost me $500, I hope it works. Otherwise, I'll wait for summer to sell this crap off.
Sash is offline   Reply With Quote
Old 02-13-2007, 09:57 PM   #14
roland1963
AF Newbie
 
Join Date: Feb 2007
Location: Berwyn, Illinois
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2006 Altima no heat when idling

I also have a 2003 Alti and have the same problem. What I have learned from other forums is this; If your radiator cap is over 2 years old, buy a replacement before stating this procedure. Lift the front end of the car on ramps or something. Any way you do it, the front end must be up. Of course, take all necessary safety percautions. Open up the radiator by removing the cap. Turn on the car and turn on the fan to the highest speed - in the heat setting. This will supposedly purge air pockets in the lines. Fill the radiator all the way up to the very top. Keep an eye on it for the level may drop (thermostat opening?) if so, keep filling all the way to the rim. When satisfied the level is no longer dropping, put the NEW cap on BEFORE shutting off the car or you may give the radiator a chance to "inhale" thus causing air in the lines again. Lower the vehicle, fill the resevoir up to the "full" mark (I'd personally fill it even higher) and cross your fingers. Hope this helps someone.
roland1963 is offline   Reply With Quote
Old 02-14-2007, 07:59 AM   #15
crazyy_e
AF Newbie
Thread starter
 
Join Date: Oct 2006
Location: Sudbury
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2006 Altima no heat when idling

Well the dealership said they took the air pockets out, on 2 different occasions. They still haven't gotten back to me about what they're going to do.... I supose we'll find out sooner or later.
crazyy_e is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Nissan > Altima

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:38 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts