Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Alfa Romeo > 156
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 07-11-2006, 04:30 PM   #1
camjamlorcol
AF Newbie
 
Join Date: Jul 2006
Location: Dunfermline
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Engine Management Light Problem

Can anybody help?
My Engine Management light has come on again and I have been told it could be numerous things from the climate control to the need for new cats.
I have looked at numerous forums and it all seems to point to either the Air Flow Meter or Lambda Sensor, then again it could be the cats need replacing.
The exhaust has not blown (as thought by the Alfa dealer), so what could it be??? HELP!!!!!!!!
camjamlorcol is offline   Reply With Quote
Old 08-30-2006, 03:36 AM   #2
franzzz
AF Newbie
 
Join Date: Nov 2003
Location: Venezia
Posts: 92
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Engine Management Light Problem

I think Lambda sensor
franzzz is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Alfa Romeo > 156

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:09 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts