Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Nissan > Almera | Sunny | Pulsar | Bluebird | Tiida | Versa | NX | Avenir | Tino | Stanza
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 07-07-2015, 02:26 AM   #1
oanica
AF Newbie
 
Join Date: Jul 2015
Location: Maputo
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
2000 Nissan Bluebird silphy 1.5 performance issues

Good day,

I drive a 2000 Nissan Bluebird silphy 1.5 petrol, and find it very nice and quiet, but after 60mph its very slow to respond and after 65mph it doesn't go further. I was suspecting the MAF but i changed it and no result, changed the spark plug and nothing, now I'm thinking about changing the fuel pump. just to be clear i tried a diagnosis and the computer says the car is OK.
I noticed a oil leak on the engine but i dont think this is causing the issue.Can you guys help me out?
oanica is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Nissan > Almera | Sunny | Pulsar | Bluebird | Tiida | Versa | NX | Avenir | Tino | Stanza

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:23 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts