Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > GMC > Jimmy
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 07-27-2011, 05:10 PM   #1
snorander
AF Newbie
 
snorander's Avatar
 
Join Date: Aug 2006
Location: Manchester, New Hampshire
Posts: 71
Thanks: 3
Thanked 0 Times in 0 Posts
Secondary Air Pump question

Ok So my check engine light came on & it was the Air pump. Picked up a used one tested it on my bench, worked great. So I installed it, cleared the error code and was happy. A week later my light came back on, same thing air pump. So I put 12v on the pump and it works fine. Light bulb goes off in my head, I never checked the maxi fuse. So sure enough the 30 amp fuse is blown. No worries I have one & put it in. Fired the truck up and don't hear/feel the pump running. So I check the fuse it's still good, check the pump it still works when I put 12V on it. SO my question is: is the secondary air pump supposed to run all the time or only run when the engine is cold? As my car was hot when I was testing it.

Thanks,

Steve
snorander is offline   Reply With Quote
Old 07-27-2011, 06:49 PM   #2
procaddytech
AF Regular
 
Join Date: Nov 2004
Location: Mechanicsville, Maryland
Posts: 256
Thanks: 1
Thanked 47 Times in 44 Posts
Re: Secondary Air Pump question

Hi Steve,
The Secondary Air Injection (AIR) System is designed to lower exhaust emission levels during a cold or warm start. The AIR pump is timed to remain ON for approximately one minute after the engine is started. If the pump is not coming on check the air pump relay either in the electrical center or attached to wiring harness. If the old pump blew the fuse due to excessive current draw the relay contacts may have been burnt before the fue finally blew. What year is your Jimmy? I can provide more accurate information and a schematic if it would help.
Tommy
procaddytech is offline   Reply With Quote
Old 07-27-2011, 07:21 PM   #3
snorander
AF Newbie
Thread starter
 
snorander's Avatar
 
Join Date: Aug 2006
Location: Manchester, New Hampshire
Posts: 71
Thanks: 3
Thanked 0 Times in 0 Posts
Re: Secondary Air Pump question

Thanks for the reply, it is a 2001 GMC Jimmy SLE. I didn't think to check the relay. does the pump turn on when I turn the key to the on position or do I actually have to start the truck for it to come on (I tried it both ways and it wasn't comming on). Will I be able to tell just by looking at the relay if it is bad?

Thanks,

Steve
snorander is offline   Reply With Quote
Old 07-27-2011, 07:53 PM   #4
procaddytech
AF Regular
 
Join Date: Nov 2004
Location: Mechanicsville, Maryland
Posts: 256
Thanks: 1
Thanked 47 Times in 44 Posts
Re: Secondary Air Pump question

The truck needs to be running. Locate the relay, it appears to be toward the front of the right fender near the battery. There should be power one of the red wires and the pink wire at the relay with the key in run. If you jump the 2 red wires the pump should run. If you can't see the wires look at the diagram on the relay and jump the switch portion. Usually 87 and 30 diagonal from each other. With a test light connected to power, backprobe the brown wire with the test light and start the truck. The light should illuminate. That will test the PCM control circuit. If all of these tests are good, the relay is bad. Notice there are other fuses to check also. You may find an identical relay for another circuit to swap for a test.

If the pump does not run with the relay jumped, check ground 100, near bottom of radiator.
procaddytech is offline   Reply With Quote
Old 07-27-2011, 08:04 PM   #5
snorander
AF Newbie
Thread starter
 
snorander's Avatar
 
Join Date: Aug 2006
Location: Manchester, New Hampshire
Posts: 71
Thanks: 3
Thanked 0 Times in 0 Posts
Re: Secondary Air Pump question

Thanks Procaddy, I'll test it when I get a chance.

Thanks again!

Steve
snorander is offline   Reply With Quote
Old 07-28-2011, 07:03 AM   #6
snorander
AF Newbie
Thread starter
 
snorander's Avatar
 
Join Date: Aug 2006
Location: Manchester, New Hampshire
Posts: 71
Thanks: 3
Thanked 0 Times in 0 Posts
Re: Secondary Air Pump question

"If the pump does not run with the relay jumped, check ground 100, near bottom of radiator. "

Thanks, I'll check the ground out as well, is that on the battery side of the truck and is it accesable from under the hood or under the truck?
snorander is offline   Reply With Quote
Old 07-28-2011, 12:43 PM   #7
procaddytech
AF Regular
 
Join Date: Nov 2004
Location: Mechanicsville, Maryland
Posts: 256
Thanks: 1
Thanked 47 Times in 44 Posts
Re: Secondary Air Pump question

You're welcome. I hope I can help out. G100 is number 5 in this illustration. Looks to be under the right headlamp area. May be easier to get to from the bottom. It runs with the forward lamp harness.
procaddytech is offline   Reply With Quote
The Following User Says Thank You to procaddytech For This Useful Post:
snorander (07-28-2011)
Old 08-03-2011, 06:34 PM   #8
snorander
AF Newbie
Thread starter
 
snorander's Avatar
 
Join Date: Aug 2006
Location: Manchester, New Hampshire
Posts: 71
Thanks: 3
Thanked 0 Times in 0 Posts
Re: Secondary Air Pump question

Thanks for the help guys! It was a bad ground, both grounds on the front were pretty bad. I hit them with some sand paper & cleaned them both up while I was there. Air pump works like a charm now.
snorander is offline   Reply With Quote
Old 04-08-2017, 04:07 PM   #9
Streaker
AF Newbie
 
Join Date: Apr 2017
Location: Los angeles, California
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Secondary Air Pump question

Hello. I have a 2001 gmc sonoma 4.3. I have been reading dozens of threads regarding the 0410 trouble codes. Symptoms are i can't get much over 2,000 rpms, no more then 55 on the freeway, on an uphill grade which isn't that steep it starts hesitating and losing power until level ground again. The motor feels like its starving for air. Not jerking like a lack of fuel. I start up cold and air pump is working then shuts off about a minute later. 0410 code comes and goes. Shows no trouble codes but engine still no power. Any suggestions? Would really appreciate some.
Thank you.
Streaker is offline   Reply With Quote
Old 04-08-2017, 04:25 PM   #10
Streaker
AF Newbie
 
Join Date: Apr 2017
Location: Los angeles, California
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Secondary Air Pump question

Btw. Before the 0410 code came on the maf trouble code came on and i replaced it. Coincidence??
Streaker is offline   Reply With Quote
 
Similar Threads
Thread Thread Starter Forum Replies Last Post
Secondary AIR Pump Relay Question FireDude312 Problem Diagnosis 7 11-15-2009 05:59 AM
Secondary Air Pump snalion Intrigue 1 08-11-2006 09:05 AM
Secondary Air Pump Won't Stop Running GeneP Sonoma | S-15 0 03-01-2006 06:05 PM
Secondary Air Pump Replacement Lazanis Blazer 1 07-11-2004 06:46 PM
'97 328i Secondary Air Pump Noise lfein 3 Series 3 05-30-2003 08:42 PM

Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > GMC > Jimmy

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:28 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts