Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > GMC > General Discussion
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 09-29-2015, 02:05 PM   #1
martinjm176
AF Newbie
 
Join Date: Sep 2015
Location: portland
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
All Electrical Power Gone!

Got in my truck to start it the other morning and no power at all to anything. next day went out in the afternoon, hooked up jumper cables to jump but I didn't need to. It started on first turn and seemed to have full power. Let it sit a day and it starts no problem. Seems to have full power. We had some problems 3 months ago and replaced the battery and had the alternator checked and they put a gauge on and said the alternator was OK, not the best but OK. Thanks!
martinjm176 is offline   Reply With Quote
Old 09-29-2015, 04:16 PM   #2
Stealthee
Your worst nightmare
 
Stealthee's Avatar
 
Join Date: Oct 2004
Location: Smithfield, Pennsylvania
Posts: 5,430
Thanks: 5
Thanked 136 Times in 133 Posts
Re: All Electrical Power Gone!

Poor grounds could cause issues similar to that.
__________________
Stealthee is offline   Reply With Quote
Old 09-29-2015, 09:51 PM   #3
MikeCStig
AF Regular
 
Join Date: Dec 2012
Location: Portland, Maine
Posts: 439
Thanks: 0
Thanked 47 Times in 47 Posts
Re: All Electrical Power Gone!

The alternator itself may be ok, but the connections (wires, terminals, etc) may be screwy. Something might be loose, there may be some corrosion, a pinched or broken wire, something of that nature.
It might help to list the year, make, and model of your truck. Some vehicles are known for certain issues, maybe you have a truck that's known for electrical problems, we don't know yet.
__________________
"Ok, systems check; the battery is discharging, the oil temperature is very high, the oil pressure is very low, the engine temperature is off the end of the scale, I'm running out of petrol... but the clock is correct!"
-James May, in an old, worn out Lamborghini purchased for less than 10,000.
MikeCStig is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > GMC > General Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:43 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts