Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > GMC > Canyon
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 06-02-2006, 12:46 PM   #1
Bigindin
AF Newbie
 
Join Date: Jun 2006
Location: Ft. Worth, Texas
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Question Canyon 'Content Theft Deterrent' Problems Starting

I have a 2004 GMC Canyon Pickup with the 5 spd and 4cyl engine. It has 53xxx miles on it. Recently, when I push-in on the clutch and turn the ignition to start, NOTHING happens until I release the key from the start position. The truck then immediately begins to and does start. This does not happen every time I start it. But when it does do this, a warning light comes on and stays on that (according to the Owner's Manual), is for the 'Content Theft Deterrent System' which this truck does NOT have. I have NO Remote Keyless Entry System.
The truck runs fine after starting it at the times this light stays on. When I turn the truck off and restart it, this may or may not occur again.
Shortly before this problem began, I began getting the message ... Change Oil...across the dash display. That display will continue until I briefly push the Odometer/Trip button and then it will not come on again until I stop and restart the truck. I had the oil changed less than 600 miles ago. Are these related?

Please Help If Y'All Can.
Thanks, Bigindin.
Bigindin is offline   Reply With Quote
Old 06-19-2006, 04:45 PM   #2
MT-2500
AF - Advisor
 
MT-2500's Avatar
 
Join Date: Sep 2005
Location: New London, Missouri
Posts: 16,692
Thanks: 5
Thanked 121 Times in 120 Posts
Re: Canyon 'Content Theft Deterrent' Problems Starting

Quote:
Originally Posted by Bigindin
I have a 2004 GMC Canyon Pickup with the 5 spd and 4cyl engine. It has 53xxx miles on it. Recently, when I push-in on the clutch and turn the ignition to start, NOTHING happens until I release the key from the start position. The truck then immediately begins to and does start. This does not happen every time I start it. But when it does do this, a warning light comes on and stays on that (according to the Owner's Manual), is for the 'Content Theft Deterrent System' which this truck does NOT have. I have NO Remote Keyless Entry System.
The truck runs fine after starting it at the times this light stays on. When I turn the truck off and restart it, this may or may not occur again.
Shortly before this problem began, I began getting the message ... Change Oil...across the dash display. That display will continue until I briefly push the Odometer/Trip button and then it will not come on again until I stop and restart the truck. I had the oil changed less than 600 miles ago. Are these related?



Please Help If Y'All Can.
Thanks, Bigindin.
Welcome to your first post on AF.

The change oil message just may need the reset procedure..
look in owners manual.
The starting may be a ign switch problem.
You can get a All Data DIY sub and look at the wiring digram and see if the ign switch is switching the proper signal to starter/relay or starter in the start position.
http://www.alldata.com/products/diy/index.html
If it kicks in when you back off of switch it may be a bad switch or need adjustment.
If you can not find the problem run it by the dealer and get them to have a look at it.
It may have a recall or tsb's { a known problem on it}
Good luck and let us know how it goes.
MT
__________________
Remember proper testing gives us the answer to many problems.
MT
MT-2500 is offline   Reply With Quote
Old 06-19-2006, 10:30 PM   #3
Bigindin
AF Newbie
Thread starter
 
Join Date: Jun 2006
Location: Ft. Worth, Texas
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Canyon 'Content Theft Deterrent' Problems Starting

Thank You Very Much Sir, for your thorough and understandable reply.
Bigindin.
Bigindin is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > GMC > Canyon

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:35 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts